Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414867 - Trying to sparsify a direct lun leads to a UI exception
Summary: Trying to sparsify a direct lun leads to a UI exception
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.3
Assignee: Shmuel Melamud
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 15:54 UTC by Idan Shaby
Modified: 2017-02-01 14:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:55:47 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
tjelinek: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1418255 0 unspecified CLOSED Error message is too general when trying to sparsify a direct lun disk 2021-02-22 00:41:40 UTC
oVirt gerrit 70978 0 master MERGED ui: Disable Sparsify for direct LUNs and Cinder disks 2017-01-24 16:23:36 UTC
oVirt gerrit 71147 0 ovirt-engine-4.1 MERGED ui: Disable Sparsify for direct LUNs and Cinder disks 2017-01-25 13:57:06 UTC

Internal Links: 1418255

Description Idan Shaby 2017-01-19 15:54:31 UTC
Description of problem:
When trying to sparsify a direct lun that is attached to a vm, a UI exception is shown.

Version-Release number of selected component (if applicable):
6968ff23b74862046be1f91201138b0d79a336ef

How reproducible:
100%

Steps to Reproduce:
1. Create a vm.
2. Create a direct lun as one of the vm disks.
3. Click on "Sparsify" when selecting this disk.

Actual results:
UI exception

Expected results:
Should work/be blocked/fail with an error.

Additional info:
It seems to be a class cast exception because of a cast from Disk to DiskImage, so I guess that it will happen with cinder disks, too.
I, personally, don't know what the right behavior should be with disks other than images, I'll leave it to you to decide.

Comment 1 Yaniv Kaul 2017-01-22 09:53:30 UTC
I'd block it.

Comment 2 sefi litmanovich 2017-02-01 11:44:07 UTC
Verified with rhevm-4.1.0.3-0.1.el7.noarch.
1. Create a vm.
2. Created a vm with direct lun as one of vm's disks.
3. Sparsify option in UI is disabled.
4. Via REST API sparsify action fails - The error message is 'Internal error' too general, opened a bug for this: https://bugzilla.redhat.com/show_bug.cgi?id=1418255


Note You need to log in before you can comment on or make changes to this bug.