Bug 1414874 - HA Validation test failing because of missing Packet sequence error handling
Summary: HA Validation test failing because of missing Packet sequence error handling
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-db
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: z2
: 10.0 (Newton)
Assignee: Raoul Scarazzini
QA Contact: Asaf Hirshberg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 16:00 UTC by Raoul Scarazzini
Modified: 2017-03-09 17:30 UTC (History)
9 users (show)

Fixed In Version: python-oslo-db-4.13.5-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 13:38:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1642944 None None None 2017-01-19 16:00:18 UTC
OpenStack gerrit 411221 None None None 2017-01-19 16:22:44 UTC
Red Hat Product Errata RHBA-2017:0355 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 Bug Fix and Enhancement Advisory 2017-03-01 18:33:11 UTC

Description Raoul Scarazzini 2017-01-19 16:00:19 UTC
Description of problem:

Package python-oslo-db is missing a way to handle a specific connection error after a failure that the environment should be able to support without problems.

Version-Release number of selected component (if applicable):

python-oslo-db-4.13.4-1.el7ost.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Stop the core resources (Galera, Redis and Rabbit)
2. Wait 20 minutes
3. Start core resources
4. Spawn an instance

Actual results:

ERROR (ClientException): Unexpected API Error. Please report this at http://bugs.launchpad.net/nova/ and attach the Nova API log if possible.
<class 'sqlalchemy.exc.OperationalError'> (HTTP 500) (Request-ID: req-71c32e29-7dae-4e63-bff8-b5a0610e0f2b)

Expected results:

Success.

Additional info:

Comment 4 Asaf Hirshberg 2017-02-27 11:35:20 UTC
Verified on osp-10 latest using provided steps by reporter.

Comment 6 errata-xmlrpc 2017-03-01 13:38:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0355.html


Note You need to log in before you can comment on or make changes to this bug.