Bug 1414879 - rebase sos to 3.4 in RHEL7.4
Summary: rebase sos to 3.4 in RHEL7.4
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos   
(Show other bugs)
Version: 7.4
Hardware: noarch Linux
high
medium
Target Milestone: rc
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
Lenka Špačková
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 16:23 UTC by Pavel Moravec
Modified: 2017-08-14 19:12 UTC (History)
8 users (show)

Fixed In Version: sos-3.4-1.el7
Doc Type: Release Note
Doc Text:
_sos_ rebased to version 3.4 The _sos_ package has been updated to upstream version 3.4, which provides a number of enhancements, new features, and bug fixes, including: * New plug-ins have been added for *ceph_ansible*, *collectd*, *crypto*, *dracut*, *gnocchi*, *jars*, *nfsganesha*, *nodejs*, *npm*, *openstack_ansible*, *openstack_instack*, *openstack_manila*, *salt*, *saltmaster*, and *storageconsole* * API plug-in enhancements * Internationalisation updates * The networking plug-in no longer crashes when a network name contains the single quote character `'` * The *foreman-debug* plug-in is now run with a longer timeout to prevent incomplete *foreman-debug* information collected * Certain private SSL certificate files are no longer collected
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 23:08:12 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2203 normal SHIPPED_LIVE sos bug fix and enhancement update 2017-08-01 19:41:56 UTC

Description Pavel Moravec 2017-01-19 16:23:15 UTC
Description of problem:
I would like to rebase sos package in RHEL7.4 to upstream 3.4 version planned to be released in March this year. Reasons:

- Since sos 3.3 GA, there have been numerous minor updates in upstream sos / sosreport that would be beneficial for CEE to get in RHEL7.4.

- there will be smaller "testing distance" between upstream and RHEL

- Rebasing will simplify downstream work, esp. later on when working on z-stream patches (some 7.2.z patches were needed to be manually rewritten due to the diff between upstream and downstream)


Version-Release number of selected component (if applicable):
sos-3.3-*


How reproducible:
100%


Steps to Reproduce:
1. rpm -q sos


Actual results:
sos-3.3-*


Expected results:
sos-3.4-*


Additional info:

Comment 12 errata-xmlrpc 2017-08-01 23:08:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2203


Note You need to log in before you can comment on or make changes to this bug.