Bug 1414890 - Fail to execute functional tests
Summary: Fail to execute functional tests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 9.0 (Mitaka)
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 16:39 UTC by Arie Bregman
Modified: 2017-04-06 11:11 UTC (History)
5 users (show)

Fixed In Version: openstack-neutron-8.3.0-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-06 11:11:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arie Bregman 2017-01-19 16:39:08 UTC
Description of problem:

Two regressions while running neutron OSP 9 functional tests:

neutron.tests.functional.agent.l3.test_dvr_router.TestDvrRouter.test_connection_from_diff_address_scope_with_fip

neutron.tests.functional.agent.linux.test_utils.TestGetRootHelperChildPid.test_get_root_helper_child_pid_returns_first_child


Version-Release number of selected component (if applicable):

openstack-neutron-8.1.2-14.el7ost.noarch
openstack-neutron-common-8.1.2-14.el7ost.noarch
openstack-neutron-openvswitch-8.1.2-14.el7ost.noarch


How reproducible: 100%


Steps to Reproduce:
1. Setup node with openstack-neutron (OSP 9)
2. Run functional tests (tox -e dsvm-functional)

Actual results: The two above tests fail.


Expected results: Tests passed successfully.

Comment 2 Assaf Muller 2017-01-19 19:46:34 UTC
Probably because we just rebased OSP 9 in https://bugzilla.redhat.com/show_bug.cgi?id=1392743?

Comment 3 anil venkata 2017-01-20 13:55:02 UTC
CI is using openstack-neutron-8.1.2-14.el7ost.noarch but the build we released after rebasing to 8.3.0 is  openstack-neutron-8.3.0-2. Need to check with Arie why CI is not updated to 8.3.0.

Comment 6 anil venkata 2017-02-07 13:39:55 UTC
@Arie
Created  openstack-neutron-8.3.0-3 with the fix. Can you please try this?

Comment 7 anil venkata 2017-03-13 05:51:11 UTC
openstack-neutron-8.3.0-3 fixing this issue.

Comment 8 Jon Schlueter 2017-03-16 12:22:27 UTC
According to our records, this should be resolved by openstack-neutron-8.3.0-3.el7ost.  This build is available now.


Note You need to log in before you can comment on or make changes to this bug.