Bug 141490 - umount of lvm volumes does not actualize /etc/mtab
umount of lvm volumes does not actualize /etc/mtab
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mount (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 11:05 EST by Francisco Jorge
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 08:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed description (2.38 KB, text/plain)
2004-12-01 11:08 EST, Francisco Jorge
no flags Details

  None (edit)
Description Francisco Jorge 2004-12-01 11:05:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I try to umount a volume created at installation time in order to 
resize it. When I umount the partition, it seems to work correctly, 
buy when I view the /etc/mtab, the entry for the partition is still 
there.

This makes other programs that rely on the contents of /etc/mtab fail.

The partition seems to be umounted, because if I try to umount it 
again I get a message saying that the partition is not mounted. The 
problem resides in the contents of /etc/mtab not been updated.

Version-Release number of selected component (if applicable):
mount-2.11y-31.1

How reproducible:
Always

Steps to Reproduce:
1. umount a lvm partition
2. cat /etc/mtab

Expected Results:  I think, the partition should have been deleted 
from /etc/mtab, or if it has been impossible to umount it, then 
umount should have returned an error.

Additional info:
Comment 1 Francisco Jorge 2004-12-01 11:08:01 EST
Created attachment 107721 [details]
Detailed description

Here you have a more detailed description of my lvm configuration.
Comment 2 Francisco Jorge 2005-01-17 06:21:09 EST
I think the problem begins if you try to umount the / partition.

when doing so, the system does not report any error, but all 
subsequent tries to umount a partition leaves /etc/mtab unchanged.

Comment 3 Karel Zak 2005-07-18 09:09:54 EDT
If you umount the root partition the file /etc/mtab is unavailable for arbitrary
command and the mount doesn't update /etc/mtab of course. Please, can you step
by step describe how reproduce your problem?
Comment 4 Karel Zak 2005-10-24 08:54:33 EDT
Since there are insufficient details provided in this report for
us to investigate the issue further, and we have not received the
feedback we requested, we will assume the problem was not
reproduceable or has been fixed in a later update for this product.

Users who have experienced this problem are encouraged to upgrade
to the latest update release, and if this issue is still
reproduceable, please contact the Red Hat Global Support Services
page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact
Red Hat at 1-888-GO-REDHAT for technical support for the problem
you are experiencing.

Note You need to log in before you can comment on or make changes to this bug.