Bug 1414905 - RHEL 7.3: BIOS corrupted after Suspend
Summary: RHEL 7.3: BIOS corrupted after Suspend
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mcelog
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Prarit Bhargava
QA Contact: Vilém Maršík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 17:14 UTC by Chuck Copello
Modified: 2018-03-01 15:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-01 15:20:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of crash text (2.88 MB, image/jpeg)
2017-01-19 17:14 UTC, Chuck Copello
no flags Details
dmidecode output (15.35 KB, text/plain)
2017-01-27 18:34 UTC, Chuck Copello
no flags Details

Description Chuck Copello 2017-01-19 17:14:42 UTC
Created attachment 1242532 [details]
Screenshot of crash text

Description of problem:
As I do everyday, I use the power button to suspend my laptop (X1 Carbon) before removing the port replicator and going home, and from using it at home and then bringing back to work. When I got home, I needed to setup my laptop to take an evening call. I saw a message about a Firmware Bug: the BIOS has corrupted hw-PMU resources (please see attached screenshot). I was able to enter my passphrase and recover. I've seen this a couple times and need to report the issue.

Version-Release number of selected component (if applicable):
RHEL 7.3,X1 Carbon laptop.

How reproducible:
1 in 10 - 20 Suspends creates this issue.

Steps to Reproduce:
1. Minimize all windows (for no good reason other than going between different monitor setups).
2. Press and momentarily hold the Power button to suspend the laptop.
3. Re-open the laptop after getting home.

Actual results:


Expected results:
Don't expect a BIOS crash.

Additional info:

Comment 2 Prarit Bhargava 2017-01-27 14:14:04 UTC
Chuck, this certainly looks like a problem.  It might be BIOS and it might be the kernel.  I'll try to figure it out.

One question: Are you putting the system into *hibernate* or suspend/resume?

P.

Comment 3 Chuck Copello 2017-01-27 15:36:53 UTC
Hi Prarit,

What I do now is a short press of the power button (not sure if that is hibernate or suspend), and this almost always allows my laptop to wake up when I undock and go home, or disconnect power & 2nd monitor when leaving home. 

What I used to do is just shut the laptop and disconnect, but when I got where I was going and re-opened the laptop, the laptop wouldn't respond and I had to fully power down via the power button. 

Thanks,

Chuck

Comment 4 Prarit Bhargava 2017-01-27 16:11:00 UTC
Thanks for the info Chuck.  One other request: could you attach the output of dmidecode to this BZ?  I'd like to see if I can chase down the *exact* X1 model you have.

P.

Comment 5 Chuck Copello 2017-01-27 18:34:27 UTC
Created attachment 1245248 [details]
dmidecode output

Here is the requested output.

Chuck

Comment 6 Prarit Bhargava 2018-03-01 15:20:57 UTC
It's been a year since I looked at this bug :(

Chuck, after a quick discussion with Lenovo they are suggesting that you update the FW on your laptop.  That issue is likely caused by the FW using the HW PMU counter even though it is reserved for the OS.

That causes an uneven count on the PMU counter -- which kicks out that error message and causes the "corruption".

P.


Note You need to log in before you can comment on or make changes to this bug.