Bug 1414915 - [RFE] Add section explaining/listing the options in the answers file
Summary: [RFE] Add section explaining/listing the options in the answers file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
: 1573070 (view as bug list)
Depends On: 1396925
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 17:37 UTC by emahoney
Modified: 2021-05-01 16:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-16 08:01:28 UTC
oVirt Team: Docs
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)

Description emahoney 2017-01-19 17:37:34 UTC
Adding a section in the engine-setup section that explains the parameters/values in the answers file would help users who attempt to automate their deployments. 

Similar to https://www.ovirt.org/develop/release-management/features/heapplianceflow/

It would be helpful if instead of a list, it was a chart with the boolean values and their meaning for each parameter.

    i.e 
       ----------------------------------------------------------------------
      |  OVEHOSTED_NETWORK/bridgeName=str:ovirtmgmt | Sets the bridge name of
      |                                             |  the interface that           
      |                                             |  will become the management
      |                                             |  network. 
       ----------------------------------------------------------------------

Comment 1 Yaniv Lavi 2017-01-31 11:33:36 UTC
Do we have a way to automate the answers and details?

Comment 2 Simone Tiraboschi 2017-02-07 08:37:06 UTC
(In reply to Yaniv Dary from comment #1)
> Do we have a way to automate the answers and details?

For sure we need to enter the descriptions somehow since now they are missing; then we probably have to patch otopi to generate the list.

Comment 3 Yaniv Lavi 2017-02-14 07:41:32 UTC
Can you please open a RFE to automate the answer file docs and block this item on that?

Comment 4 Yedidyah Bar David 2017-02-14 08:22:27 UTC
(In reply to Yaniv Dary from comment #3)
> Can you please open a RFE to automate the answer file docs and block this
> item on that?

I'd rather close current bug wontfix. Our current handling of the answer files is not always trivial to document.

See also:

bug 1396925 - for a better approach (imho). If we go this route, we won't need extra documentation.

https://www.ovirt.org/develop/developer-guide/engine/engine-setup/ - for the way answer files are currently intended to be generated/used.

Comment 11 Ido Rosenzwig 2018-04-30 10:42:41 UTC
*** Bug 1573070 has been marked as a duplicate of this bug. ***

Comment 12 Sam McLeod 2018-04-30 22:10:57 UTC
(In reply to Yedidyah Bar David from comment #4)
> (In reply to Yaniv Dary from comment #3)

Thank you both Yedidyah and Yaniv, I appreciate you taking the time to respond.

I see that bug 1396925 has been closed, is there an open bug to track this?


Note You need to log in before you can comment on or make changes to this bug.