Bug 1414919 - Openvswitch undirectional traffic throughput performance less than 1/2 bidirectional throughput
Summary: Openvswitch undirectional traffic throughput performance less than 1/2 bidire...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Kevin Traynor
QA Contact: Christian Trautman
URL:
Whiteboard:
: 1414939 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 17:51 UTC by bmichalo
Modified: 2018-02-09 13:27 UTC (History)
9 users (show)

Fixed In Version: openvswitch-2.6.1-16.git20161206.el7fdb
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-12 15:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 14 Christian Trautman 2017-06-08 19:03:53 UTC
Reproduced on 
DPDK 16.11-3
OVS 2.6.1-3

Uni-directional traffic was less than half of bi-directional traffic. One thing I did notice is when running bi-directional traffic one port would be running much less than the other when running a 100% flow rate. IE (One port receiving 8 Mpps and the other at 5 Mpps). After updating to openvswitch-2.7.0-6.git20170530.el7fdb.x86_64 the issue has resolved. Uni-directional traffic comes out to half of bi-directional and the ports in bi-directional show the same pps on each port when running at 100%. 

Verified same behaviour on openvswitch-2.6.1-16.git20161206.el7fdb

Comment 16 Flavio Leitner 2018-02-09 13:27:41 UTC
*** Bug 1414939 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.