Bug 1414935 - Tap-to-click and scrolling often ignored on Synaptics SynPS/2
Summary: Tap-to-click and scrolling often ignored on Synaptics SynPS/2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 25
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: PrioritizedBug
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 18:46 UTC by Laurentiu Pancescu
Modified: 2017-03-01 09:27 UTC (History)
8 users (show)

Fixed In Version: libinput-1.6.0-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 20:21:28 UTC


Attachments (Terms of Use)
sudo evemu-record /dev/input/event5 (31.55 KB, text/plain)
2017-01-19 18:46 UTC, Laurentiu Pancescu
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 99447 None None None 2017-01-30 10:48:03 UTC

Description Laurentiu Pancescu 2017-01-19 18:46:54 UTC
Created attachment 1242545 [details]
sudo evemu-record /dev/input/event5

Description of problem:
Tap-to-click is often ignored, as well as scrolling using the touchpad. Tap-to-click is especially annoying, it happens very often, and I normally see between 1 and 5-6 taps being ignored. I see this on two different netbook models with F25 XFCE, the problems started around 2-3 days ago on both netbooks - one is running the i686 arch, the other x86_64.  I performed a fresh installation of F24 XFCE x86_64 on one of them, and the problems disappeared completely.

Version-Release number of selected component (if applicable):
0.23.0-2.fc25.i686

How reproducible:
Happens every few seconds of usage, but it seems random.

Steps to Reproduce:
1. Just tap to click inside Firefox, on XFCE's Applications menu, or anywhere else

Actual results:


Expected results:


Additional info:
I attached an evemu-record log. I left the mouse cursor immobile above the Firefox window in the background, with the terminal in the foreground, and tapped-to-click. When Firefox came to the foreground, I used Alt-Tab to bring the terminal again to the front. The last tap-to-click was recorded by evemu-record, but it didn't bring Firefox to the foreground.  I was able to reproduce this with multiple evemu-record runs, it happens quite often - for the log I attached, I stopped recording as soon as I saw it happen for the first time, to be sure I can point out at the correct instance of the event. If there's something else I can try or debug, please let me know (I guess I'll have to switch the other netbook to either F24 or Debian on Sunday, it's very frustrating to use - but I can wait if I can assist with fixing this).

Comment 1 Laurentiu Pancescu 2017-01-20 21:32:42 UTC
"dnf history" shows libinput was upgraded on 2017-01-17. After downgrading from 1.5.901-1.fc25.i686 to 1.5.0-1.fc25.i686, the problem disappeared: not even a single tap was ignored during several hours of intensive testing. Reassigning to libinput.

Comment 2 Laurentiu Pancescu 2017-01-21 13:56:59 UTC
Version libinput-1.6.0-1.fc25.i686 from testing shows the same problem as 1.5.901-1.fc25.i686: taps are randomly ignored.

Comment 3 Martin Kho 2017-01-22 15:50:15 UTC
Hi,

Same happens here in KDE plasma5. Downgrading to 1.5.0-2 makes tapping working again.
martin@localhost ~]$ xinput list 
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=11   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ HP HD Webcam [Fixed]                      id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=13   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=14   [slave  keyboard (3)]

[martin@localhost ~]$ xinput list-props 12
Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (138):   1
        Coordinate Transformation Matrix (140): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Tapping Enabled (291): 1
        libinput Tapping Enabled Default (292): 0
        libinput Tapping Drag Enabled (293):    1
        libinput Tapping Drag Enabled Default (294):    1
        libinput Tapping Drag Lock Enabled (295):       0
        libinput Tapping Drag Lock Enabled Default (296):       0
        libinput Tapping Button Mapping Enabled (297):  1, 0
        libinput Tapping Button Mapping Default (298):  1, 0
        libinput Accel Speed (273):     0.000000
        libinput Accel Speed Default (274):     0.000000
        libinput Natural Scrolling Enabled (278):       0
        libinput Natural Scrolling Enabled Default (279):       0
        libinput Send Events Modes Available (258):     1, 1
        libinput Send Events Mode Enabled (259):        0, 0
        libinput Send Events Mode Enabled Default (260):        0, 0
        libinput Left Handed Enabled (280):     0
        libinput Left Handed Enabled Default (281):     0
        libinput Scroll Methods Available (282):        1, 1, 0
        libinput Scroll Method Enabled (283):   1, 0, 0
        libinput Scroll Method Enabled Default (284):   1, 0, 0
        libinput Disable While Typing Enabled (299):    1
        libinput Disable While Typing Enabled Default (300):    1
        Device Node (261):      "/dev/input/event6" 
        Device Product ID (262):        2, 7
        libinput Drag Lock Buttons (289):       <no items> 
        libinput Horizontal Scroll Enabled (290):       1
HTH

Martin Kho

Comment 4 Peter Hutterer 2017-01-23 00:02:24 UTC
this is probably a side-effect of: http://who-t.blogspot.com.au/2016/12/libinput-touchpad-tap-analysis.html

Comment 5 Laurentiu Pancescu 2017-01-23 07:14:58 UTC
I only now realized you're the upstream developer. :)  I see a few values above 100ms in my evemu log (the first instinct was to believe the sensor didn't register my tap, so I tapped a bit harder, which probably only increases the touch time).  It'd be interesting to see if the average touch time increases during the day - I assume I be slower when tired.

I assume this means a WONTFIX, right? In any case, clicking with the physical buttons works, but I'm unable to reduce the assigned severity - "urgent" seems overblown.

https://cgit.freedesktop.org/wayland/libinput/commit/?id=d0ba1e2b383acaac8a31a1ded7d3039bcd161db3

Comment 6 Garrett LeSage 2017-01-23 08:45:03 UTC
Version 1.5 worked like a dream on my XPS 9360; between the still-too-slow speed of 1.6 and especially this tap-to-click dropping approximately half of my taps makes my laptop's touchpad go from a dream-to-use to a nightmare.

It's so frustrating to use my laptop now. The only options I have are either downgrade to 1.5 (which I did for the time being), always plug in a mouse into a laptop I bought specifically because the touchpad hardware is so good, or toss the new laptop across the room in frustration.

I do appreciate your work on libinput and your efforts to improve it. (Thanks!) However, for at least this specific hardware, it is a major regression and has severely hurt the functionality, rendering the touchpad annoyingly unusable for those of us who depend on touch events.

Comment 7 Andy Lutomirski 2017-01-23 18:13:25 UTC
I filed #1415793 for the acceleration regression.

Comment 8 Peter Hutterer 2017-01-30 00:43:17 UTC
upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=99447

Comment 9 Fedora Update System 2017-02-01 05:50:00 UTC
libinput-1.6.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d4096aee0

Comment 10 Fedora Update System 2017-02-01 23:51:24 UTC
libinput-1.6.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7d4096aee0

Comment 11 Fedora Update System 2017-02-02 20:21:28 UTC
libinput-1.6.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.