Bug 1414968 - Cinnamon unresponsive, time gap grows over time.
Summary: Cinnamon unresponsive, time gap grows over time.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon-screensaver
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 20:34 UTC by Michal Schorm
Modified: 2017-03-06 10:26 UTC (History)
2 users (show)

Fixed In Version: cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc25 cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 08:49:36 UTC


Attachments (Terms of Use)

Description Michal Schorm 2017-01-19 20:34:33 UTC
Hi, help please.

I got this problem all the time since F24, (now on F25) on various laptops.

-------------

Description:
*Something* happens.

Then some parts of the cinnamon starts to be unresponsive.
Mainly the "screen brightness up/down" buttons. Then the lock screen. Then even "su" command!
What's more, the time, when it is unresponsive grows over time!
First, it can be second, or two ... or ten. Then minutes.

The real problem is, that you, for example, set "brightness up".
But nothing happens. For a minute. You want to walk of your laptop, so you want to lock it, but you can't because it is unresponsive. So you sit down and use a keaboard shortcut to open file manager and terminal. But they are frozen too.
So you click on the terminal icon, and want to restart your computer. You enter "su". But well ... it freeze for a while too.

It is really annoying andit can occur few times a day in a scale I have to force restart the laptop.

-------------

I haven't ever found any hint, what could cause it, however, I experience it more often, when I put the machine to sleep mode and wake it up a few times. (wich is my basic usecase through a day)



Don't hesistate to "needinfo" me on everything you would need.

Comment 1 Fedora Update System 2017-02-20 11:23:40 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-855ed02f31

Comment 2 Fedora Update System 2017-02-20 11:24:50 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cfb76d98fc

Comment 3 Michal Schorm 2017-02-20 12:34:35 UTC
Thanks for investigation.

I installed the package from Bodhi updates, however, my feedback can be delayed, since I have no idea, what cause this bug.

Comment 4 Fedora Update System 2017-02-20 20:23:49 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cfb76d98fc

Comment 5 Fedora Update System 2017-02-20 21:22:48 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-855ed02f31

Comment 6 Michal Schorm 2017-02-21 23:41:07 UTC
As i mentioned in the Bodhi, this update ^ did not solved the issue.

However, I have more information:

When it happens, it breaks mounting.
Whatever you pick - USB flash drive, external HDD or SD card, it can't be mounter with error message "Not authorized to perform this operation".

I checked "dmesg", seems alright.
I checked "journalctl -xe", but I don't know, what to look for.

for example (?):
"úno 22 00:24:02 my-ntb python3[15165]: detected unhandled Python exception in '/usr/share/cinnamon-screensaver/cinnamon-screensaver-command.py'
"


Give me some suggestions where to look and for what, and I'll try to catch the cause or make some reproducer.

Comment 7 Fedora Update System 2017-02-28 08:49:36 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-03-01 01:20:36 UTC
cinnamon-screensaver-3.2.14-0.2.20170124git5561f3c.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Michal Schorm 2017-03-06 10:26:55 UTC
Unfortunatelly, I'm still strucked with this issue :/
But hey, I have some new info!

Recently, I ran 'dnf upgrade', which, after some research showed, I must have somehow damaged systemd.
Systemd scripts are looping infinitely, deamons fails to restart and so on ...

I believe, this could be the cause of delays and freezes.


Now the bad news:
I fight with this bug daily since F24, for more than half a year. I re-installed Fedora dozens times, without MAJOR configuration (of course, I install my beloved programs and stuff for work and configure the environment, but I never touched 'deep' settings of the system)


I'll leave this bug report closed for now, and I'll start to solve this with systemd guys.


Note You need to log in before you can comment on or make changes to this bug.