Bug 1414969 - Gnome fails to remove Install Pending Updates option
Summary: Gnome fails to remove Install Pending Updates option
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit
Version: 7.3
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 20:35 UTC by Joseph D. Wagner
Modified: 2021-01-15 07:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:31:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Joseph D. Wagner 2017-01-19 20:35:50 UTC
Description of problem:
When shutting down from Gnome, gnome fails to clear the "Install Pending Updates" option if updates are installed via another mechanism, such as straight from the command line.

Version-Release number of selected component (if applicable):
gnome-shell-3.14.4-53.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. When updates are available, goto shutdown, and see the option
2. Cancel the shutdown.
3. run yum upgrade
4. When finished, goto shutdown. The option is still there.

Actual results:
The option is still there.

Expected results:
The option should be gone.

Additional info:
The option persists, even after restart.

This bug used to exist in Fedora, but it has since been resolved.

I'm not sure if gnome-shell is the correct package to report this against, or if it is some other package like gnome-session.

Comment 1 Florian Müllner 2017-03-14 21:23:26 UTC
That sounds like a PackageKit issue.

Comment 3 RHEL Program Management 2021-01-15 07:31:02 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.