Bug 1414979 - [RFE] Containerized deployment of Ceph
Summary: [RFE] Containerized deployment of Ceph
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Emilien Macchi
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1411504 (view as bug list)
Depends On: 1386911
Blocks: 1414974 1442136 1476046
TreeView+ depends on / blocked
 
Reported: 2017-01-19 21:24 UTC by jomurphy
Modified: 2018-02-05 19:04 UTC (History)
22 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170721174554.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1476046 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:02:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description jomurphy 2017-01-19 21:24:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 John Fulton 2017-03-23 11:37:13 UTC
I thought the plan was to containerize Ceph using ceph-ansible and not change puppet-ceph to do this. So, perhaps we need a title change to "Containerized deployment of Ceph" without the "make puppet-ceph containerized". 

If so, then I would think this would be a dependency of the following: 

 https://bugzilla.redhat.com/show_bug.cgi?id=1386911

Since all deployments of Ceph with TripleO from Pike forward when it uses ceph-ansible would be containerized Ceph.

Comment 4 Federico Lucifredi 2017-04-26 23:24:05 UTC
*** Bug 1411504 has been marked as a duplicate of this bug. ***

Comment 7 John Fulton 2017-07-28 14:18:56 UTC
Patches linked from https://bugzilla.redhat.com/show_bug.cgi?id=1386911 have merged and they (only) deploy containerized Ceph (so you could argue this is a duplicate). Moving to post.

Comment 14 Yogev Rabl 2017-10-26 17:16:19 UTC
verified

Comment 17 errata-xmlrpc 2017-12-13 21:02:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.