Bug 141500 - xorg hard locks machine switching to text mode
xorg hard locks machine switching to text mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-12-01 12:36 EST by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 07:48:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg configuration file (3.47 KB, text/plain)
2005-02-01 04:08 EST, Alessandro Polverini
no flags Details
xorg log file (bzip2 compressed) (9.08 KB, application/octet-stream)
2005-02-01 04:19 EST, Alessandro Polverini
no flags Details

  None (edit)
Description Alessandro Polverini 2004-12-01 12:36:47 EST
Description of problem:

If I press ctrl-alt-F1 to switch to text mode the pc locks hard.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.1-12.FC3.1

How reproducible:
Always.

Additional info:
Graphic Card is ATI Radeon 9600 with two flat panels.

lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]
00:0a.0 Ethernet controller: Marvell Technology Group Ltd. Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter (rev 13)
00:0b.0 Communication controller: Tiger Jet Network Inc. Tiger3XX
Modem/ISDN interface
00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0e.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN
interface
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA
RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge
[KT600/K8T800 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AQ
[Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AQ [Radeon
9600] (Secondary)

lspci -n:
00:00.0 Class 0600: 1106:3188 (rev 01)
00:01.0 Class 0604: 1106:b188
00:0a.0 Class 0200: 11ab:4320 (rev 13)
00:0b.0 Class 0780: e159:0001
00:0c.0 Class 0200: 10ec:8139 (rev 10)
00:0e.0 Class 0280: e159:0001
00:0f.0 Class 0104: 1106:3149 (rev 80)
00:0f.1 Class 0101: 1106:0571 (rev 06)
00:10.0 Class 0c03: 1106:3038 (rev 81)
00:10.1 Class 0c03: 1106:3038 (rev 81)
00:10.2 Class 0c03: 1106:3038 (rev 81)
00:10.3 Class 0c03: 1106:3038 (rev 81)
00:10.4 Class 0c03: 1106:3104 (rev 86)
00:11.0 Class 0601: 1106:3227
00:11.5 Class 0401: 1106:3059 (rev 60)
00:18.0 Class 0600: 1022:1100
00:18.1 Class 0600: 1022:1101
00:18.2 Class 0600: 1022:1102
00:18.3 Class 0600: 1022:1103
01:00.0 Class 0300: 1002:4151
01:00.1 Class 0380: 1002:4171
Comment 1 Philip Van Hoof 2004-12-02 05:13:08 EST
This is a duplicate of Bug 138503
Comment 2 Mike A. Harris 2005-01-31 23:57:33 EST
I see this is an AMD64 system.  Does this problem occur both
with 32bit OS installation and 64bit OS installation?  Please
indicate which you've tried, and which works/does not work.

Also attach your X server config file, log file, and /var/log/messages
as individual uncompressed file attachments, using the link below.

This may be a dupe of bug #138503 but I would like to see the
details first before drawing that conclusion.
Comment 3 Mike A. Harris 2005-02-01 00:00:56 EST
Setting status to "NEEDINFO", awaiting information requested in
comment #2 above.
Comment 4 Alessandro Polverini 2005-02-01 04:08:28 EST
Created attachment 110488 [details]
xorg configuration file

Altough my machine is 64bit I'm still using 32bit fedora on it, waiting to
switch to 64bit as soon as all the issues I have are fixed (mainly some sw not
ported to 64 bit)
Comment 5 Alessandro Polverini 2005-02-01 04:19:50 EST
Created attachment 110489 [details]
xorg log file (bzip2 compressed)

I'm sorry I have to attach the file bzcompressed because my dsl has problem on
uploading and the submit aborts after a while if the file is too big :(
Comment 6 Alessandro Polverini 2005-02-01 04:21:43 EST
My /var/log/messages is quite huge, please specify which part is
relevant for you.

Thanks,
Alex
Comment 7 Alessandro Polverini 2005-02-01 04:23:04 EST
To answer your first question (sorry if I do so many followups), I
only tested with 32bit fedora, and not with the 64bit version.
Comment 8 Mike A. Harris 2005-02-01 05:19:45 EST
Ok, make sure your system is fully updated with all FC3 update
rpms, including the kernel, and that you're rebooted into the
latest official FC3 kernel.  Then please upgrade to rawhide
xorg-x11-6.8.1.903 or later, as there have been a number of radeon
driver fixes since FC3, and this release will be released for FC3
in the very near future, so it is important to know if you still
experience the issue in what will become 6.8.2 soon.

For /var/log/messages, just reboot the system and then after
the X problem is triggered, attach the messages log from boot
onward, so we can see everything that has happened since boot.

This should ensure the log file is not too huge.

Thanks in advance.

Setting status to "NEEDINFO", awaiting feedback of testing of
rawhide xorg-x11.
Comment 9 Alessandro Polverini 2005-02-01 07:48:03 EST
Hello Mike,
upgrading to xorg-x11-6.8.1.903 solved the issue :)

I suppose the bug can be closed now.

Thanks,
Alex

Note You need to log in before you can comment on or make changes to this bug.