Bug 1415000 - Base Runtime FTBFS: realmd-0.16.2-7.fc25
Summary: Base Runtime FTBFS: realmd-0.16.2-7.fc25
Keywords:
Status: CLOSED ERRATA
Alias: None
Deadline: 2017-02-02
Product: Fedora
Classification: Fedora
Component: realmd
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sumit Bose
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BaseRuntimeFTBFS
TreeView+ depends on / blocked
 
Reported: 2017-01-19 22:42 UTC by Merlin Mathesius
Modified: 2017-01-24 03:20 UTC (History)
5 users (show)

Fixed In Version: realmd-0.16.2-8.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 03:20:02 UTC
Type: Bug


Attachments (Terms of Use)
proposed patch to correct FTBFS issue (1.06 KB, patch)
2017-01-19 22:44 UTC, Merlin Mathesius
no flags Details | Diff

Description Merlin Mathesius 2017-01-19 22:42:45 UTC
Description of problem:
When attempting to rebuild portions of the frozen package set of Fedora 25 for the Base Runtime effort, we discovered that realmd fails to build due to a missing BuildRequires on python due to python being removed from the default buildroot. This issue also manifests itself in Rawhide where only python3 is present in the buildroot.

Version-Release number of selected component (if applicable):
realmd-0.16.2-7.fc25

How reproducible:
Every time

Steps to Reproduce (rawhide):
1. fedpkg clone readmd
2. fedpkg switch-branch master
3. fedpkg mockbuild

Actual results:
/bin/sh: ./build/tap-driver: /usr/bin/python: bad interpreter: No such file or directory

Expected results:
Successful build of the package.

Additional info:
This is needed as part of the Base Runtime effort.

Attached is a patch that adds the missing BuildRequires on python.

Please apply the patch or respond with a reason it should not be applied within two weeks. After that time, a provenpackager will go ahead and apply it.

Comment 1 Merlin Mathesius 2017-01-19 22:44:49 UTC
Created attachment 1242624 [details]
proposed patch to correct FTBFS issue

Comment 2 Fedora Update System 2017-01-20 09:39:50 UTC
realmd-0.16.2-8.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3eff2a543

Comment 3 Sumit Bose 2017-01-20 09:40:51 UTC
Thank you for the patch, feel free to give karma to the update.

Comment 4 Merlin Mathesius 2017-01-20 14:58:30 UTC
Thank you for the quick fix!

Comment 5 Fedora Update System 2017-01-20 19:56:44 UTC
realmd-0.16.2-8.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3eff2a543

Comment 6 Fedora Update System 2017-01-24 03:20:02 UTC
realmd-0.16.2-8.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.