Bug 1415006 - Filter by Environment drop down box does not work when applying from Content -> Errata -> Apply
Summary: Filter by Environment drop down box does not work when applying from Content ...
Keywords:
Status: CLOSED DUPLICATE of bug 1431254
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Errata Management
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 23:40 UTC by Craig Donnelly
Modified: 2019-08-12 15:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 20:40:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Craig Donnelly 2017-01-19 23:40:48 UTC
Description of problem:
Likely related to RHBZ #1415005:
Under Content -> Errata -> Apply, there is a drop-down box to select a Lifecycle Environment to easily filter hosts on this page to choose from for applying the selected errata, when changing it to /any/ Lifecycle Environment available in the list, it does not take effect. All hosts are visible in the list.

Version-Release number of selected component (if applicable): 6.2.6

How reproducible: 100%

Steps to Reproduce:
1. Goto Content -> Errata.
2. Click some errata, and click 'Apply'.
3. Click 'Filter by Environment' drop-down box and choose any environment, all hosts are still visible

Actual results:
Drop-down box does not filter content hosts list

Expected results:
Should only see content hosts in selected lifecycle environment.

Additional info:
If you ignore this drop-down box and instead use the filter box, you can instead filter this way successfully (Valid workaround):
lifecycle_envrironment = 'Production'.

Comment 2 Brad Buckingham 2017-09-21 20:40:26 UTC

*** This bug has been marked as a duplicate of bug 1431254 ***


Note You need to log in before you can comment on or make changes to this bug.