Bug 1415015 - Cannot generate certificate / private key
Summary: Cannot generate certificate / private key
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 00:24 UTC by Jaroslav Škarvada
Modified: 2017-06-23 11:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-23 11:35:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Jaroslav Škarvada 2017-01-20 00:24:17 UTC
Description of problem:
It seems that certificate / private key generation stopped working. If "generate certificate" in CA control panel is selected (I tried Comodo and StartSSL) some dialog flashes very quickly (it's impossible to read), no error is displayed, but no private key is generated and the generated certificate is unusable.

Version-Release number of selected component (if applicable):
firefox-50.1.0-1.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Generate free Comodo S/MIME certificate on: https://secure.comodo.com/products/frontpage?area=SecureEmailCertificate
2. Click the certificate collect link in the received e-mail

Actual results:
Error that there is no private key to pair the certificate with is displayed, no certificate is stored.

Expected results:
No error, certificate stored.

Additional info:
IIRC it worked correctly in f24. I didn't try with new user/profile. Also both Comodo an StartSSL works correctly in Firefox on Windows 10.

Comment 1 Martin Stransky 2017-06-20 09:55:42 UTC
Yes, I can reproduce that. What flashes here is password manager prompt to save password. It also prints on console:

Strict-Transport-Security: The site specified a header that could not be parsed successfully.

Comment 2 Jan Horak 2017-06-23 11:35:15 UTC
It seems to be problem with the page, not the browser. The certificate arrived to the mail eventually (with some delay, like few hours).


Note You need to log in before you can comment on or make changes to this bug.