Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415028 - setup VNC based on xinetd with XDMCP for GDM on RHEL7.2 Failed
Summary: setup VNC based on xinetd with XDMCP for GDM on RHEL7.2 Failed
Keywords:
Status: CLOSED DUPLICATE of bug 1283925
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tigervnc
Version: 7.2
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 01:56 UTC by Zeng Yiquan
Modified: 2020-03-11 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 06:06:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Zeng Yiquan 2017-01-20 01:56:46 UTC
Description of problem:

When we setup VNC based on xinetd with XDMCP for GDM on RHEL7.2 follow the kcs as below:

https://access.redhat.com/solutions/2516

At last step:

[root@R72 ~]# vncviewer localhost:5950

TigerVNC Viewer 64-bit v1.3.1 (20150902)
Built on Sep  2 2015 at 11:19:20
Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Fri Jan 20 09:45:27 2017
 CConn:       connected to host localhost port 5950
 CConn:       End of stream
[root@R72 ~]# 

and log message as below:

Jan 20 09:45:27 R72 xinetd[12233]: START: vnc01-640x480x16 pid=14726 from=::1
Jan 20 09:45:27 R72 kernel: Xvnc[14726]: segfault at 0 ip 0000000000527267 sp 00007ffdac64c4b0 error 4 in Xvnc[400000+238000]
Jan 20 09:45:27 R72 xinetd[12233]: EXIT: vnc01-640x480x16 signal=11 pid=14726 duration=0(sec)

Version-Release number of selected component (if applicable):

[root@R72 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
[root@R72 ~]# yum list tigervnc*
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed Packages
tigervnc.x86_64                                                  1.3.1-3.el7                                   @LocalISO    
tigervnc-icons.noarch                                            1.3.1-3.el7                                   @LocalISO    
tigervnc-license.noarch                                          1.3.1-3.el7                                   @anaconda/7.2
tigervnc-server.x86_64                                           1.3.1-3.el7                                   @LocalISO    
tigervnc-server-minimal.x86_64                                   1.3.1-3.el7                                   @anaconda/7.2
[root@R72 ~]# 

How reproducible:


Steps to Reproduce:
1. yum install gdm tigervnc tigervnc-server xinetd
2. systemctl enable xinetd.service
3. vim /etc/gdm/custom.conf
[xdmcp]
Enable=true
4. vim  /etc/xinetd.d/xvncserver
5. vim /etc/services
6. init 3
7. init 5
8. vncviewer localhost:5950

Actual results:

[root@R72 ~]# vncviewer localhost:5950

TigerVNC Viewer 64-bit v1.3.1 (20150902)
Built on Sep  2 2015 at 11:19:20
Copyright (C) 1999-2011 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Fri Jan 20 09:45:27 2017
 CConn:       connected to host localhost port 5950
 CConn:       End of stream
[root@R72 ~]# 

Expected results:

It should be a pop-up window for user to login.

Additional info:

Only on RHEL7.3 can success.
and on RHEL7.2 i can see the abrt message as below:

[root@R72 ~]# cat /var/spool/abrt/ccpp-2017-01-19-17\:05\:58-14875/package 
tigervnc-server-minimal-1.3.1-3.el7

so i # yum update tigervnc-server-minimal -y and that issue is disappeared

Comment 1 Jan Grulich 2017-01-20 06:06:03 UTC
Duplicate of bug 1283925 and fixed in RHEL 7.3 and I think even backported as z-stream.

*** This bug has been marked as a duplicate of bug 1283925 ***


Note You need to log in before you can comment on or make changes to this bug.