Bug 1415036 - [Docs][Manual Install] Update procedures for setting up integration test suite
Summary: [Docs][Manual Install] Update procedures for setting up integration test suite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: async
: 10.0 (Newton)
Assignee: Lukas Ruzicka
QA Contact: Charelle Collett
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 03:17 UTC by Leon Tseng
Modified: 2017-05-30 10:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 10:52:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
please check out the object test part. (2.15 MB, text/plain)
2017-01-20 03:17 UTC, Leon Tseng
no flags Details

Description Leon Tseng 2017-01-20 03:17:14 UTC
Created attachment 1242653 [details]
please check out the object test part.

Description of problem:

Some errors in this section(https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/single/manual-installation-procedures/#sect-tempest-configure), lists below:

1. In 17.2.2, command "/usr/share/openstack-tempest/tools/configure-tempest-directory" doesn't exist, the command "ln -s /usr/share/openstack-tempest-13.0.0 /usr/share/openstack-tempest" should be executed first to create a link.

2. in 17.2.4, the command for creating "tempest.conf" is not correct. the part "object-storage.operator_role Member" should be changed to "object-storage.operator_role swiftoperator"

3. in 17.2.5, the commands "python -m tempest.cmd.cleanup --init-saved-state" and "python -m tempest.cmd.cleanup" don't work, they should be "tempest cleanup --init-saved-state" and "tempest cleanup"

Version-Release number of selected component (if applicable):

13.0.0-7.bafe630git.el7ost.noarch


How reproducible:

Following the link to run tempest test:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/single/manual-installation-procedures/#sect-tempest-configure

Then lots of unnecessary failures will appear in the tempest result.


Actual results:

1. no such file in the first bug

2. lots of object storage tests failed caused by the non-exist role Member in the second bug

3. tempest cleanup function doesn't work


Expected results:

1. command "/usr/share/openstack-tempest/tools/configure-tempest-directory" should be exist

2. object storage tests should all pass

3. tempest cleanup utility should be able to clean the garbages after running tempest test


Additional info:

Comment 1 Lucy Bopf 2017-05-29 04:51:58 UTC
Assigning to Lukas for review.

Comment 2 Lukas Ruzicka 2017-05-29 08:27:11 UTC
Created attachment 1283172 [details]
Corrected version

This is the corrected version according to the reported bug.

Comment 5 Chandan Kumar 2017-05-29 09:07:05 UTC
Hello Lukas,

(In reply to Lukas Ruzicka from comment #3)
> Hi Chandar,
> I changed the procedure according to the comments in the reported bug. Could
> you please confirm that it is now correct (see attachment)?
>

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/manual_installation_procedures/#sect-tempest-configure

In step 17.2, step 2: this command "/usr/share/openstack-tempest/tools/configure-tempest-directory" will be replaced with /usr/share/openstack-tempest-*/tools/configure-tempest-directory"

The rest change is ok.

Can you update this part also:
yum install python-glance-tests python-keystone-tests python-horizon-tests-tempest python-neutron-tests python-cinder-tests python-nova-tests python-swift-tests python-ceilometer-tests python-gnocchi-tests python-aodh-tests to 
yum install python-glance-tests python-keystone-tests \
 python-horizon-tests-tempest python-neutron-tests \
 python-cinder-tests python-nova-tests python-swift-tests \
python-ceilometer-tests python-gnocchi-tests python-aodh-tests
python-zaqar-test python-mistral-tests ?

Thanks,

Chandan Kumar

Comment 6 Lukas Ruzicka 2017-05-29 09:32:27 UTC
I made the required changes. I am attaching a pdf to illustrate them.

Comment 7 Lukas Ruzicka 2017-05-29 09:38:54 UTC
Created attachment 1283197 [details]
Updated corrected version for review

Comment 9 Charelle Collett 2017-05-30 00:08:15 UTC
Looks good to me, Lukas.  Merged.


Note You need to log in before you can comment on or make changes to this bug.