This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 141504 - During install the DVI monitor has flickering image
During install the DVI monitor has flickering image
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-12-01 12:50 EST by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 10:23:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alessandro Polverini 2004-12-01 12:50:14 EST
Description of problem:
I've a radeon 9600 with two flat panels, one on the DVI output and the
other one attached on the analog output.

During install they both have the same image, but the screen on the
DVI output is not readable because the screen behaves like it has been
set a bad frequency (i.e.: the image rolls very fast and is distorted).

I was able to install just because I had also the analog flat panel.

Version-Release number of selected component (if applicable):

Don't know how to get this one: is the installer of FC3.

Relevant lines from lspci [-n]:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AQ
[Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AQ [Radeon
9600] (Secondary)
01:00.0 Class 0300: 1002:4151
01:00.1 Class 0380: 1002:4171

How reproducible:

Always.

Steps to Reproduce:
1. Get a radeon 9600
2. Put two flat panels, one on the analog output, and the other one on
the DVI output
3. boot from the install CD
Comment 1 Mike A. Harris 2005-01-31 23:47:42 EST
Do a forced text mode installation, and after installing, configure
the system to boot up into runlevel 3.  Update your entire system
with the latest Fedora Core 3 updates, and reboot into the latest
kernel.

After you've updated your system, run:

    system-config-display --reconfig

Now try switching to runlevel 5 by doing "init 5".  If the problem
still persists, reboot again, and upgrade to the xorg-x11 in
Fedora development (rawhide), which is currently 6.8.1.903 (6.8.2rc3)
slated for release in a few weeks.  We will be releasing 6.8.2
as an official FC3 update shortly, so it is important to test this
new version.

If the problem still exists with rawhide xorg-x11, please update
the bug report with status updates.  Also, please attach your
X server log file, config file, and /var/log/messages as individual
uncompressed file attachments.  We also recommend filing a bug
report in X.Org bugzilla at http://bugs.freedesktop.org in the
"xorg" component to maximize the likelyhood of someone finding
a solution should the problem still persist.

Thanks in advance.
Comment 2 Mike A. Harris 2005-01-31 23:52:12 EST
Setting status to "NEEDINFO", awaiting upstream bug report URL, and
the results of testing xorg-x11 from rawhide.
Comment 3 Alessandro Polverini 2005-02-01 04:33:38 EST
Sorry but I do not understand exactly why I need to do that test: my
system works just fine with both flat panels, the problems I have are
switching to text mode (#141500), and flickering of the DVI monitor
*during* the install (this bug).
After the install, X works fine with both monitors.
Comment 4 Mike A. Harris 2005-03-22 10:23:39 EST
We need additional information in order to troubleshoot the problem,
including getting you to test some things and provide us with the
feedback of your testing.

If X works fine on both monitors after installation, that is rather confusing
because it is the exact same X server and video driver being used in
the installer, and after install.  The only thing I can think of which might
be different is wether your flat panel gets detected correctly by the
hardware probing code outside of the X server (ddcprobe).

In any case, if we were to isolate the problem and fix it, you'd have to
install an update to get the fix, it wont be on the CD image, so there
is probably no way to solve this problem if it only occurs on the initial
FC3 installation only.

We have released an update into FC3-testing of xorg-x11-6.8.2.  Please
upgrade to this new release, and if the problem persists with 6.8.2 in
FC4-test1 or later OS releases or test releases, please reopen this report
and provide details.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.