Bug 1415056 - [IntService_public_324] Ansible install failed at task import_jks_certs on multiple node OCP env where master is disabled for pod scheduling
Summary: [IntService_public_324] Ansible install failed at task import_jks_certs on mu...
Keywords:
Status: CLOSED DUPLICATE of bug 1415057
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 06:21 UTC by Xia Zhao
Modified: 2017-01-20 21:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 21:31:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xia Zhao 2017-01-20 06:21:39 UTC
Description of problem:
In order to track similar problem for logging about jks-cert-gen pod's scheduling on multiple nodes OCP env when master is diabled for pod scheduling, as is described by https://bugzilla.redhat.com/show_bug.cgi?id=1414477.

The workaround is to only enable pod scheduling on OCP master (diable scheduling on every node):
$ oadm manage-node ${master} --schedulable=true
$ oadm manage-node ${each-of-the-nodes} --schedulable=false

Version-Release number of selected component (if applicable):
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0

How reproducible:
Always

Steps to Reproduce:
1.Please refer to "Description of problem"
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jeff Cantrill 2017-01-20 13:26:08 UTC
I believe this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1415057  Same root cause

Comment 2 Jeff Cantrill 2017-01-20 21:31:03 UTC
Closing as it is same fundamental issue

*** This bug has been marked as a duplicate of bug 1415057 ***


Note You need to log in before you can comment on or make changes to this bug.