Bug 1415058 - [trello 60kr8WOB] Events tab of StatefulSet page does not show existent event
Summary: [trello 60kr8WOB] Events tab of StatefulSet page does not show existent event
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 06:29 UTC by Xingxing Xia
Modified: 2017-05-30 12:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 12:50:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xingxing Xia 2017-01-20 06:29:31 UTC
Description of problem:
Events tab of StatefulSet page does not show existent event

Version-Release number of selected component (if applicable):
openshift v1.5.0-alpha.2+2543fed-29

How reproducible:
Always

Steps to Reproduce:
1. Create StatefulSet with steps in https://bugzilla.redhat.com/show_bug.cgi?id=1414709#c0
2. Check events in CLI
$ oc describe statefulset hello
3. On web console, click Applications --> Stateful Sets --> hello --> Events tab, check events
4. On web console, click Monitoring --> View Details (at upper right), check events of Stateful Set

Actual results:
2. It shows events:
oc describe statefulset hello
Name:			hello
Namespace:		xxia-proj
Image(s):		aosqe/hello-openshift
...
Pods Status:		1 Running / 0 Waiting / 0 Succeeded / 0 Failed
No volumes.
Events:
  FirstSeen	LastSeen	Count	From		SubObjectPath	Type		Reason			Message
  ---------	--------	-----	----		-------------	--------	------			-------
  34s		34s		1	{statefulset }			Normal		SuccessfulCreate	pet: hello-0

3. It does not show event, just displaying "No events to show"
4. There is Stateful Set event same as CLI in step 2:
1:47:31 PM 	hello 	Stateful Set 	Normal 	Successful create  	pet: hello-0

Expected results:
3. Events tab should show event

Additional info:
** By the way, click Monitoring page, there is no Stateful Set item. Is it missed or intended? **

Comment 2 Xingxing Xia 2017-01-22 07:42:20 UTC
Checked in openshift v1.5.0-alpha.2+6e9d68d-91. Now Events tab of StatefulSet page works correctly, it can display/filter/sorts correctly for statefulset events:
1:55:17 PM 	Normal 	Successful create  	pet: hello-0
1:55:22 PM 	Normal 	Successful create  	pet: hello-1
1:58:46 PM 	Normal 	Successful create  	pet: hello-2
2:37:58 PM 	Normal 	Successful delete  	pet: hello-2
2:37:58 PM 	Normal 	Successful delete  	pet: hello-1


> Additional info:
> ** By the way, click Monitoring page, there is no Stateful Set item. Is it missed or intended? **

Monitoring page still has no statefulset. What's should be expected about statefulset in this page?

Comment 3 Jessica Forrester 2017-01-23 14:48:25 UTC
We had a PR for the monitoring page that was supposed to merge on friday but it flaked.  It is merged now.

Comment 4 Yadan Pei 2017-01-24 05:58:08 UTC
Checked against openshift v1.5.0-alpha.2+b61bed3-113

1. Create statefulset
2. oc edit statefulset  //change replicas to 3
3. oc edit statefulset  //then change replicas back to 1
4. On web console, click Applications --> Stateful Sets --> hello --> Events tab
- Events for StatefulSets are shown correctly on Events tab

5. On web console, click Monitoring --> View Details
- Events for StatefulSets are also shown correctly on Events page browse/events

Move to VERIFIED

Comment 5 bpeterse 2017-03-13 14:04:43 UTC
Yup merged.


Note You need to log in before you can comment on or make changes to this bug.