Bug 1415077 - RFE: map rawhide to proper id for client
Summary: RFE: map rawhide to proper id for client
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: frontend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 07:52 UTC by Pavel Raiskup
Modified: 2017-05-20 21:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-20 21:43:09 UTC


Attachments (Terms of Use)

Description Pavel Raiskup 2017-01-20 07:52:25 UTC
Unexpected output:

    $ copr mock-config praiskup/postgresql-rhbz1348125 fedora-rawhide-x86_64

    Something went wrong:
    Error: Chroot not found.

Expected behavior:
Because it is really convenient way to work with Fedora Rawhide, copr should
map 'fedora-rawhide' to 'fedora-N' correctly and do the right thing
transparently.

Comment 1 Pavel Raiskup 2017-01-20 07:56:36 UTC
Another issue is that the actual mock does not provide 'fedora-26-x86_64'
chroot.  So the command:

  $ copr mock-config praiskup/postgresql-rhbz1348125 fedora-26-x86_64

Provides non-working mock profile.

Comment 2 Pavel Raiskup 2017-01-20 07:59:26 UTC
FTR: reported in time when 'fedora-rawhide-x86_44' builds against f26-build
target in koji.  So those should be equivalent.

Comment 3 clime 2017-05-20 21:43:09 UTC
I think this is no longer relevant so closing this. Feel free to reopen if this is still a problem.


Note You need to log in before you can comment on or make changes to this bug.