Bug 1415089 - [abrt] java-1.8.0-openjdk-headless: signalHandler(): java killed by SIGABRT
Summary: [abrt] java-1.8.0-openjdk-headless: signalHandler(): java killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1402819
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:55c80f64365bc0af525d7fa474a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 08:33 UTC by Mikko Tiihonen
Modified: 2017-01-20 09:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 09:09:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (147.99 KB, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: cgroup (209 bytes, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: core_backtrace (85.97 KB, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: dso_list (7.25 KB, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: environ (3.62 KB, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: limits (1.29 KB, text/plain)
2017-01-20 08:33 UTC, Mikko Tiihonen
no flags Details
File: maps (31.38 KB, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details
File: mountinfo (3.66 KB, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details
File: namespaces (102 bytes, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details
File: open_fds (3.18 KB, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details
File: var_log_messages (297 bytes, text/plain)
2017-01-20 08:34 UTC, Mikko Tiihonen
no flags Details

Description Mikko Tiihonen 2017-01-20 08:33:43 UTC
Description of problem:
Trying to get a screenshot from phantomjs when running selenium tests when running inside wayland.

Version-Release number of selected component:
java-1.8.0-openjdk-headless-1.8.0.111-5.b16.fc26

Additional info:
reporter:       libreport-2.9.0
backtrace_rating: 3
cmdline:        java -Dphantomjs.binary.path=/home/mtiihone/angular-main-app/node_modules/phantomjs-prebuilt/lib/phantom/bin/phantomjs -jar /home/mtiihone/angular-main-app/node_modules/protractor/node_modules/webdriver-manager/selenium/selenium-server-standalone-3.0.1.jar -port 45038
crash_function: signalHandler
executable:     /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.111-5.b16.fc26.x86_64/jre/bin/java
global_pid:     16023
kernel:         4.10.0-0.rc4.git1.2.fc26.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Mikko Tiihonen 2017-01-20 08:33:51 UTC
Created attachment 1242667 [details]
File: backtrace

Comment 2 Mikko Tiihonen 2017-01-20 08:33:52 UTC
Created attachment 1242668 [details]
File: cgroup

Comment 3 Mikko Tiihonen 2017-01-20 08:33:55 UTC
Created attachment 1242669 [details]
File: core_backtrace

Comment 4 Mikko Tiihonen 2017-01-20 08:33:56 UTC
Created attachment 1242670 [details]
File: dso_list

Comment 5 Mikko Tiihonen 2017-01-20 08:33:58 UTC
Created attachment 1242671 [details]
File: environ

Comment 6 Mikko Tiihonen 2017-01-20 08:33:59 UTC
Created attachment 1242672 [details]
File: limits

Comment 7 Mikko Tiihonen 2017-01-20 08:34:01 UTC
Created attachment 1242673 [details]
File: maps

Comment 8 Mikko Tiihonen 2017-01-20 08:34:03 UTC
Created attachment 1242674 [details]
File: mountinfo

Comment 9 Mikko Tiihonen 2017-01-20 08:34:04 UTC
Created attachment 1242675 [details]
File: namespaces

Comment 10 Mikko Tiihonen 2017-01-20 08:34:06 UTC
Created attachment 1242676 [details]
File: open_fds

Comment 11 Mikko Tiihonen 2017-01-20 08:34:07 UTC
Created attachment 1242677 [details]
File: proc_pid_status

Comment 12 Mikko Tiihonen 2017-01-20 08:34:09 UTC
Created attachment 1242678 [details]
File: var_log_messages

Comment 13 Severin Gehwolf 2017-01-20 09:09:31 UTC
There is an issue with java.awt.Robot.createScreenCapture() when running on wayland.

#11 Java_sun_awt_X11_XRobotPeer_getRGBPixelsImpl (env=0x7f2628017258, cls=<optimized out>, xgc=<optimized out>, x=0, y=0, width=3840, height=2160, pixelArray=0x7f2698b284c8) at /usr/src/debug/java-1.8.0-openjdk-1.8.0.111-5.b16.fc26.x86_64/openjdk/jdk/src/solaris/native/sun/awt/awt_Robot.c:268

Seems to suggest it's originating from that call. Marking as duplicate of 1402819. The workaround so far is running Gnome on X until there is proper wayland support in OpenJDK.

*** This bug has been marked as a duplicate of bug 1402819 ***


Note You need to log in before you can comment on or make changes to this bug.