Bug 1415093 - With perl-libwww-perl-6.05-2 https_proxy environment variable is not honored by default
Summary: With perl-libwww-perl-6.05-2 https_proxy environment variable is not honored ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl-libwww-perl
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 08:57 UTC by Martin Kyral
Modified: 2017-01-20 09:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1400632
Environment:
Last Closed: 2017-01-20 09:50:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Kyral 2017-01-20 08:57:51 UTC
The same problem is with perl-libwww-perl-6.05-2.el7. This bug shall be fixed to prevent regressions upon upgrade from RHEL 6.9 to RHEL 7.x.

+++ This bug was initially created as a clone of Bug #1400632 +++

Description of problem:

With perl-libwww-perl-5.883-2 the $env{https_proxy} variable ceases to be honoured


Version-Release number of selected component (if applicable):
perl-libwww-perl-5.883-2 

How reproducible:
Always

Steps to Reproduce:
1. check soap_test.pl script

Actual results:
Never connects to webproxy

Expected results:
Should connect to web proxy

Additional info:
Verified via Wireshark & tcpdump that the server never attempts to use the web proxy

--- Additional comment from Petr Pisar on 2016-12-02 06:46:53 EST ---

How to test:

(1) Use LWP::UserAgent without env_proxy option to connect to an HTTPS server while https_proxy environment variable is set to a HTTP proxy server and verify the TCP connection is opened to the proxy server, not to the HTTPS server. Example:

$ https_proxy=http://localhost:80 perl -e 'use LWP::UserAgent; LWP::UserAgent->new->get(q{https://localhost:443/})'

Before: There it connects to localhost:443.
After: It connects to localhost:80.

(2) Repeat the same with HTTPS_PROXY with the same results as in (1).

(3) Specify https_proxy without the "http://" schema. It should also work.

Please note that this applies to HTTPS proxy. Not to HTTP (http_proxy or HTTP_PROXY) variables. Please also note that it does not apply to LWP::UserAgent->new() invocations that have env_proxy argument.

Comment 2 Petr Pisar 2017-01-20 09:50:47 UTC
No, this feature will not be implemented in RHEL-7 or later.

The RHEL-6 bug #1400632 is to restore compatibility with previous RHEL-6 code because we changed default HTTPS implementation in the middle of RHEL-6 life cycle.

RHEL-7 uses the new HTTPS implementation as default since the beginning and is in line with upstream intention to stop using the old HTTPS implementation.


Note You need to log in before you can comment on or make changes to this bug.