Bug 1415099 - when enabling Satellite Managed DB repository fails, there is nothing in the install log
Summary: when enabling Satellite Managed DB repository fails, there is nothing in the ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Ales Dujicek
URL:
Whiteboard:
: 1391874 (view as bug list)
Depends On: 1426685
Blocks: 1340444 sat580-low
TreeView+ depends on / blocked
 
Reported: 2017-01-20 09:21 UTC by Jan Hutař
Modified: 2017-06-21 12:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:17:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2017-01-20 09:21:07 UTC
Description of problem:
When enabling Satellite Managed DB repository fails, there is nothing in the install log


Version-Release number of selected component (if applicable):
Beta candidate: Satellite-5.8-RHEL-6-20170118.0-Satellite-x86_64-dvd1.iso


How reproducible:
always


Steps to Reproduce:
1. # /mnt/tmp/install.pl --managed-db
   Make sure Managed DB fails - how? No idea :)
2. # less /var/log/rhn/rhn_installation.log


Actual results:
# /mnt/tmp/install.pl --managed-db
* Starting Red Hat Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHSM Registration.
RHSM Username? <user>
RHSM Password? <pass>
HTTP Proxy Hostname? <squid>
HTTP Proxy Port [8080]? 3128
HTTP Proxy Username? 
RHSM Profile Name [sat-mandb.example.com]? 
* RHSM Subscriptions.
Successfully attached a subscription for: Red Hat Satellite Employee Subscription
** Subscriptions: Subscription providing 'Red Hat Satellite 5 Managed DB Beta' successfully attached.
** Subscriptions: Subscription providing 'Red Hat Enterprise Linux Server' already attached.
** Subscriptions: Disabling all RHSM repositories (rhel-ha-for-rhel-6-server-rpms, rhel-lb-for-rhel-6-server-rpms, rhel-6-server-rpms).
** Subscriptions: All repositories disabled.
** Subscriptions: Enabling RHEL repository.
** Subscriptions: RHEL repository enabled.
** Subscriptions: Enabling Managed DB repository.
** Subscriptions: Enabling Satellite Managed DB repository failed. Stopping installation.
# cat /var/log/rhn/rhn_installation.log
Installation log of Red Hat Satellite
(RHEL6)
Command: /mnt/tmp/install.pl --managed-db

The system has been registered with ID: 7d0e68d2-d507-4f21-84e3-4d1f9b8d3c97


Expected results:
There should be some error message logged in install log which would give me some clues on what was wrong.

Comment 3 Gennadii Altukhov 2017-02-24 16:26:44 UTC
The error should be logged in /var/log/rhsm/rhsm.log because we use subscription-manager to enable repos. But there is nothing about the error. Create BZ for subscription-manager 1426685

Comment 4 Gennadii Altukhov 2017-05-09 13:57:16 UTC
This is Satellite only bug and not affected upstream.

Comment 7 Jan Hutař 2017-05-11 14:42:44 UTC

*** This bug has been marked as a duplicate of bug 1391874 ***

Comment 8 Grant Gainey 2017-05-19 15:00:16 UTC
Reopening - this BZ is the one that has the fix-information in it, so I'm going to keep this one ON_QA and close 1391874 as the dup instead.

Comment 9 Grant Gainey 2017-05-19 15:01:09 UTC
*** Bug 1391874 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.