Bug 1415103 - Overcloud deployment failure with swap.yaml
Summary: Overcloud deployment failure with swap.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: z3
: 10.0 (Newton)
Assignee: Emilien Macchi
QA Contact: Alex Schultz
URL:
Whiteboard:
: 1445419 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 09:46 UTC by Manabu Ori
Modified: 2021-03-11 14:54 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.2.0-17.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-28 14:44:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 418273 0 None MERGED Fix for AllNodesExtraConfig and fix environment files to create swap files/partitions 2020-06-14 14:08:44 UTC
OpenStack gerrit 424079 0 None MERGED Fix for AllNodesExtraConfig and fix environment files to create swap files/partitions 2020-06-14 14:08:44 UTC
Red Hat Product Errata RHBA-2017:1585 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-06-28 18:42:51 UTC

Description Manabu Ori 2017-01-20 09:46:17 UTC
Description of problem:
Overcloud deployment with swap{,-partition}.yaml fails.
There seems to be a fix in upstream and I confirmed the fix is applicable in OSP10.
Would you backport the fix to OSP10?

Version-Release number of selected component (if applicable):
RHOSP10
openstack-tripleo-heat-templates-5.1.0-7.el7ost.noarch

How reproducible:
Repeatedly

Steps to Reproduce:
1. Prepare for swap.yaml.
$ cat swap.yaml
resource_registry:
  OS::TripleO::AllNodesExtraConfig: extraconfig/all_nodes/swap.yaml
parameter_defaults:
  swap_size_megabytes: '2048'
  swap_path: '/swap'

2. Deploy with the swap.yaml.
openstack overcloud deploy -e swap.yaml

Actual results:
"openstack overcloud deploy" fails with error messages below:

Removing the current plan files
Uploading new plan files
Started Mistral Workflow. Execution ID: 9cab0094-a1a8-44ef-816e-7316f9f5d824
Plan updated
Deploying templates in the directory /tmp/tripleoclient-eGj7Wz/tripleo-heat-templates
Started Mistral Workflow. Execution ID: 6821c889-ddd7-4345-958f-d622db5120a2
{u'execution': {u'id': u'6821c889-ddd7-4345-958f-d622db5120a2',
                u'input': {u'container': u'overcloud',
                           u'queue_name': u'0770ebf2-6f9e-405b-86fe-4b9ae1964ad0',
                           u'timeout': 150},
                u'name': u'tripleo.deployment.v1.deploy_plan',
                u'params': {},
                u'spec': {u'input': [u'container',
                                     {u'timeout': 240},
                                     {u'queue_name': u'tripleo'}],
                          u'name': u'deploy_plan',
                          u'tasks': {u'add_validation_ssh_key': {u'name': u'add_validation_ssh_key',
                                                                 u'on-complete': u'deploy',
                                                                 u'type': u'direct',
                                                                 u'version': u'2.0',
                                                                 u'workflow': u'tripleo.validations.v1.add_validation_ssh_key_parameter container=<% $.container %>'},
                                     u'deploy': {u'action': u'tripleo.deployment.deploy timeout=<% $.timeout %> container=<% $.container %>',
                                                 u'name': u'deploy',
                                                 u'on-error': u'set_deployment_failed',
                                                 u'on-success': u'send_message',
                                                 u'type': u'direct',
                                                 u'version': u'2.0'},
                                     u'send_message': {u'action': u'zaqar.queue_post',
                                                       u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',
                                                                                                       u'message': u"<% $.get('message', '') %>",
                                                                                                       u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},
                                                                  u'queue_name': u'<% $.queue_name %>'},
                                                       u'name': u'send_message',
                                                       u'retry': u'count=5 delay=1',
                                                       u'type': u'direct',
                                                       u'version': u'2.0'},
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'<% task(deploy).result %>',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'}},
                          u'version': u'2.0'}},
 u'message': u'Failed to run action [action_ex_id=d5ce92c9-9394-4cf2-adbb-2178d26deb8a, action_cls=\'<class \'mistral.actions.action_factory.DeployStackAction\'>\', attributes=\'{}\', params=\'{u\'container\': u\'overcloud\', u\'timeout\': 150}\']\n ERROR: Failed to validate: : resources.AllNodesExtraConfig: : "" is not a map',
 u'status': u'FAILED'}

Expected results:
Successfully deployed the overcloud nodes with swap area.

Additional info:
Alex Schultz kindly told me that this is hitting an upstream bug[1] and already fixed in upstream[2].
I applyed diff from [3] to OSP10 and then swap area was successfully created in overcloud nodes.

[1] https://bugs.launchpad.net/tripleo/+bug/1652184
[2] https://review.openstack.org/#/c/418273/
[3] https://review.openstack.org/#/c/418273/6/overcloud.j2.yaml

Comment 3 Alex Schultz 2017-03-21 20:53:43 UTC
Verified deployment works with -e /usr/share/openstack-tripleo-heat-templates/environments/enable-swap.yaml provided by openstack-tripleo-heat-templates-5.2.0-6.el7ost.noarch

Comment 6 errata-xmlrpc 2017-06-28 14:44:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1585

Comment 7 atelang 2017-09-21 14:37:51 UTC
*** Bug 1445419 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.