Bug 1415113 - QE that sshd authentication via SSSD works on RHEL Atomic 7.3.2
Summary: QE that sshd authentication via SSSD works on RHEL Atomic 7.3.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.3
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On: 1337856 1403270
Blocks: 1186913 1561841 1595542
TreeView+ depends on / blocked
 
Reported: 2017-01-20 10:09 UTC by Jan Pazdziora
Modified: 2019-03-06 01:00 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1403270
: 1595542 (view as bug list)
Environment:
Last Closed: 2018-06-26 18:44:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2035 None None None 2018-06-26 18:45:14 UTC

Comment 1 Jan Pazdziora 2017-01-20 10:11:36 UTC
Verification of bug 1403270 seems to have only included sesearch but no functional verification of sshd authentication via SSSD on Atomic was made.

Hence this bugzilla to properly verify that the regression was fixed.

Comment 4 Daniel Walsh 2017-01-20 15:25:33 UTC
Ok Jan what are you seeing?  What AVCs are being generated?

Comment 8 Luwen Su 2018-06-15 10:37:14 UTC
$ sudo atomic host status
State: idle
Deployments:
● ostree://rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.5.1.1 (2018-05-22 00:51:05)
                    Commit: c28680604bc84f472804a8f8c787917496739bc61529cbee7c474f68d4daeb81

  ostree://rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.5.1 (2018-04-19 14:39:11)
                    Commit: 506129139134ad61959180b1ea6be373812abe8062b7a1c95341ae3e994bd63b


In sssd container:
#cat /proc/self/attr/current
system_u:system_r:container_t:s0:c126,c804

(The rhel7.4 image in my machine has some problems that can't do the upgrade, i'm looking for a fresh one).

I'd like to leave this open for a while until the next atomic image is out to see if everything is fine.

Comment 9 Luwen Su 2018-06-25 03:38:43 UTC
$sudo atomic host status
State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.4.2 (2017-10-17 02:47:56)
                    Commit: 2eceacd73c4de494ff3f90448467934614cf9f72cb316693db2cad47bd79015e
$ sudo docker run -it rhel7/sssd /bin/bash
# cat /proc/self/attr/current 
system_u:system_r:svirt_lxc_net_t:s0:c469,c501


$sudo atomic host upgrade
$sudo systemctl reboot

$ sudo atomic host status
State: idle
Deployments:
● ostree://rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.5.1.1 (2018-05-22 00:51:05)
                    Commit: c28680604bc84f472804a8f8c787917496739bc61529cbee7c474f68d4daeb81

  ostree://rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.4.2 (2017-10-17 02:47:56)
                    Commit: 2eceacd73c4de494ff3f90448467934614cf9f72cb316693db2cad47bd79015e
$ sudo docker run -it rhel7/sssd /bin/bash
# cat /proc/self/attr/current
system_u:system_r:container_t:s0:c449,c612

the sssd container doesn't run in runtime anymore, move to verified.

Comment 10 Jan Pazdziora 2018-06-25 06:13:22 UTC
Moving back to ON_QA. The comment 0 asks to test that ssh authentication works, something I don't see was VERIFIED in the previous comments.

Comment 12 Jan Pazdziora 2018-06-26 06:08:07 UTC
Moving back to ON_QA again.

Comment 13 errata-xmlrpc 2018-06-26 18:44:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2035


Note You need to log in before you can comment on or make changes to this bug.