Bug 1415115 - client process crashed due to write behind translator
Summary: client process crashed due to write behind translator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: write-behind
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1414247 1418623 1418624
TreeView+ depends on / blocked
 
Reported: 2017-01-20 10:29 UTC by Raghavendra G
Modified: 2017-05-30 18:39 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1414247
: 1418623 1418624 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:39:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-20 10:40:56 UTC
REVIEW: http://review.gluster.org/16440 (performance/write-behind: access stub only if available during statedump) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Worker Ant 2017-02-02 04:48:26 UTC
REVIEW: https://review.gluster.org/16440 (performance/write-behind: access stub only if available during statedump) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Worker Ant 2017-02-02 04:51:43 UTC
REVIEW: https://review.gluster.org/16440 (performance/write-behind: access stub only if available during statedump) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Worker Ant 2017-02-02 10:02:34 UTC
COMMIT: https://review.gluster.org/16440 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 85d7f1d1ee24ac400d4aa223478727643532693a
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Fri Jan 20 16:09:13 2017 +0530

    performance/write-behind: access stub only if available during
    statedump
    
    Change-Id: Ia5dd718458a5e32138012f81f014d13fc6b28be2
    BUG: 1415115
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: https://review.gluster.org/16440
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 5 Raghavendra G 2017-02-10 05:00:40 UTC
bt from core dump:
========================
warning: core file may not match specified executable file.
Reading symbols from /usr/sbin/glusterfsd...Reading symbols from /usr/lib/debug/usr/sbin/glusterfsd.debug...done.
done.
Missing separate debuginfo for 
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/5b/9ed38e31ce6bd04ecca183ad6d6ee05a4535d0
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/sbin/glusterfs --volfile-server=10.70.36.82 --volfile-server=10.70.36.83 -'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fa230684e5b in __wb_dump_requests (head=head@entry=0x7fa2100256b8, prefix=prefix@entry=0x7fa2354b9370 "xlator.performance.write-behind.wb_inode")
    at write-behind.c:2355
2355	                        gf_proc_dump_write ("offset", "%"PRId64,
Missing separate debuginfos, use: debuginfo-install glibc-2.17-157.el7_3.1.x86_64 keyutils-libs-1.5.8-3.el7.x86_64 krb5-libs-1.14.1-27.el7_3.x86_64 libcom_err-1.42.9-9.el7.x86_64 libgcc-4.8.5-11.el7.x86_64 libselinux-2.5-6.el7.x86_64 libuuid-2.23.2-33.el7.x86_64 openssl-libs-1.0.1e-60.el7.x86_64 pcre-8.32-15.el7_2.1.x86_64 zlib-1.2.7-17.el7.x86_64
(gdb) bt
#0  0x00007fa230684e5b in __wb_dump_requests (head=head@entry=0x7fa2100256b8, prefix=prefix@entry=0x7fa2354b9370 "xlator.performance.write-behind.wb_inode")
    at write-behind.c:2355
#1  0x00007fa23068510e in wb_inode_dump (this=<optimized out>, inode=0x7fa2281dc590) at write-behind.c:2424
#2  0x00007fa238f0b550 in inode_dump (inode=0x7fa2281dc590, prefix=0x7fa2354ba420 "xlator.mount.fuse.itable.active.2") at inode.c:2367
#3  0x00007fa238f0b78f in inode_table_dump (itable=0x7fa21400fa90, prefix=prefix@entry=0x7fa235ce5994 "xlator.mount.fuse.itable") at inode.c:2408
#4  0x00007fa235ccaa2b in fuse_itable_dump (this=<optimized out>) at fuse-bridge.c:5103
#5  0x00007fa238f25722 in gf_proc_dump_xlator_info (top=<optimized out>) at statedump.c:504
#6  0x00007fa238f25cb9 in gf_proc_dump_info (signum=signum@entry=10, ctx=0x7fa23ad83010) at statedump.c:830
#7  0x00007fa2393eec3e in glusterfs_sigwaiter (arg=<optimized out>) at glusterfsd.c:2069
#8  0x00007fa237d5adc5 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fa23769f73d in clone () from /lib64/libc.so.6
(gdb)

Comment 6 Shyamsundar 2017-05-30 18:39:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.