Bug 1415138 - "Confirm duplicate bug" contains an incomplete list of possible differences
Summary: "Confirm duplicate bug" contains an incomplete list of possible differences
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 5.0
Assignee: Jeff Fearn 🐞
QA Contact: Jeff Fearn 🐞
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 11:28 UTC by Radek Bíba
Modified: 2018-12-09 06:29 UTC (History)
2 users (show)

Fixed In Version: 5.0.4-rh2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 10:14:48 UTC


Attachments (Terms of Use)

Description Radek Bíba 2017-01-20 11:28:10 UTC
Description of problem:
I'm closing a dev bug as a dupe of a docs bug and Bugzilla tells me this:

====
Confirm duplicate bug

WARNING: You are marking bug 1374443 as a duplicate of bug 1362337 however the version or product is different.
Please confirm that this is what you want.

Key 	bug 1374443 	bug 1362337
Product 	Red Hat Update Infrastructure for Cloud Providers 	Red Hat Update Infrastructure for Cloud Providers
Component 	Dev-Tools 	Documentation
Version 	3.0.0 	3.0.0
====
Well, neither the version nor the product is different. It's the component.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always if the product, component, or version of the other bug differs.

Steps to Reproduce:
1. Try to close a bug in product P1, component C1, and version V1 as a dupe of another bug in product P1, component C2, and version V1.

Actual results:
BZ says ...the version or product is different.

Expected results:
Just for the sake of completeness:
BZ says ...the version, component, or product is different.

Comment 2 Jeff Fearn 🐞 2018-03-16 07:16:26 UTC
I'm just going to remove the fields from the string as the fields are variable.

Comment 3 Jeff Fearn 🐞 2018-04-11 07:51:37 UTC
Text now reads: "however the version, component, or product is different." These are the only three fields that are used for this comparison.

Comment 4 Radek Bíba 2018-04-11 08:00:15 UTC
Thanks!

Comment 5 Jeff Fearn 🐞 2018-04-18 10:14:48 UTC
This bug has been resolved in Red Hat Bugzilla 5 and can be tested on https://beta-bugzilla.redhat.com

If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.