Bug 141515 - ssh x forwarding broken
ssh x forwarding broken
Status: CLOSED DUPLICATE of bug 137685
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 14:07 EST by Gerald Teschl
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 15:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2004-12-01 14:07:07 EST
Description of problem:
x11 forwarding via ssh is broken. Some apps like xterm work, but
most don't (including system-config-*)



Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1
openssh-3.9p1-7

How reproducible:
100%

Steps to Reproduce:
1. Login to a FC3 box
2. ssh to some remote box (FC1,2,3 or RH9)
3. start (e.g.) system-config-date

  
Actual results:
Some X11 error (BadWindow with sysstem-config-*, BadAtom with gvim)

Expected results:
window popping up

Additional info:
From a remote administration point of view this is probably the WORST thing you
could break;-(
Comment 1 Sitsofe Wheeler 2004-12-01 18:10:40 EST
This is a dup of Bug 141056
Comment 2 Sitsofe Wheeler 2004-12-01 18:11:25 EST
Sorry, that should have been bug 134425
Comment 3 Mike A. Harris 2004-12-02 14:06:02 EST
As per the FC3 release notes, you must invoke "ssh -Y" in order
to get full X11 forwarding.  Please refer to the FC3 release
notes, and the openssh documentation for details.

This is not a bug.
Comment 4 Gerald Teschl 2004-12-03 04:22:06 EST
First of all: I did read the relase notes! However, "Some applications may not function properly"
is a joke! The only app which I could find that works is xterm!? But xterm over ssh is as useless
as a fridge at the northpole! So what sense does it makes to change ssh x11 forwarding if
it breaks pretty much everything you want to use it for? If the intention was full customer
dissatisfaction, then you succeeded.
Comment 5 Mike A. Harris 2004-12-03 12:25:18 EST
This is a change made by the upstream "openssh" project.  I'm not
sure why they made this change, but they did.  I also agree it is
a very annoying and inconvenient change, but we ship it as upstream
supplies it currently.

I encourage users who are inconvenienced and upset about this issue
to please discuss it on the fedora mailing lists.  I'm no authority
on openssh, or wether we would change the upstream default, however
if any sort of user concensus can be reached on the lists, perhaps
it may weigh in on such a decision.

Thanks for your feedback!
Comment 6 Tomas Mraz 2005-01-31 15:43:58 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.