Bug 1415204 - non admin user is not able to upload packages to the yum type repository
Summary: non admin user is not able to upload packages to the yum type repository
Keywords:
Status: CLOSED DUPLICATE of bug 1429624
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 14:44 UTC by Roman Bobek
Modified: 2020-12-14 08:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-31 19:42:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1429624 0 high CLOSED "Upload Package" section not showing in the WebUI for non-admin user 2021-02-22 00:41:40 UTC

Internal Links: 1429624

Description Roman Bobek 2017-01-20 14:44:16 UTC
Description of problem:
When I create a non admin user with a role which contains all permissions (most importantly the 'destroy_products' permission) from 'Products and Repositories' resource group, I'm not able to upload a new packages in the repository of type yum. The upload dialog is completely missing.


Steps to Reproduce:
1. Create new user (Administer > Users > New User), assign him e-mail, organization, location and password (tested on Internal authorization method)
2. Create new role (Administer > Roles > New Role)
3. In the role create New filter with following permissions:
      * Resource type: Product and Repositories
      * Selected items: 
         create_products
         edit_products
         destroy_products
         sync_products
         export_products
	 view_products
4. Assign the role to the created user (Administer > Users > user > Roles tab > Choose the role > Submit
5. Choose some custom product with repository type 'yum'
6. Click the repository


Actual results:
The upload dialog is completely missing.


Expected results:
The upload dialog is present and the user is allowed to upload packages into the repository.


Additional info:
* I have tested this on Satellite 6.2.4 and it's working there
* The relevant permission, which grants access to the upload dialog is probably destroy_products
* Same setup on Satellite 6.2.6 does not work
* On both 6.2.4 and 6.2.6 the user with this permissions is not allowed to create new repository in the product

Comment 1 Marek Hulan 2017-01-20 15:11:50 UTC
This does not seem to be generic permissions issue rather than the page with upload form does not check specific permission correctly. Moving to repositories component.

Comment 4 Brad Buckingham 2017-02-01 13:09:35 UTC
Hello Roman,

I am not able to reproduce the issue with the steps above on 6.2.4, 6.2.6 or on the upstream.

If I remove the 'destroy_products' permission, I am able to reproduce it.  Is that the scenario/configuration that you intended to report?  If not, if you have an internal reproducer, can we access it?

In other words, the user has the following permissions:
  Resource: Product and Repositories
  Permissions: view_products, create_products, edit_products, destroy_products, sync_products, export_products

And not the following:
  Resource: Product and Repositories
  Permissions: view_products, create_products, edit_products, sync_products, export_products

Comment 5 Brad Buckingham 2017-02-01 14:20:29 UTC
I am seeing the exact same behavior on both 6.2.4 and 6.2.6; therefore, access to an internal reproducer (if one is available) would be useful.

Comment 6 Roman Bobek 2017-02-08 12:21:06 UTC
(In reply to Brad Buckingham from comment #5)
> I am seeing the exact same behavior on both 6.2.4 and 6.2.6; therefore,
> access to an internal reproducer (if one is available) would be useful.

Hello Brad,

this is strange. I'm testing it on 6.2.7 and it works fine now. The destroy_products was present at the role before. I will update the customer and ask him for verification.

Regards,


-Roman

Comment 7 Brad Buckingham 2017-03-08 19:18:14 UTC
Hi Roman,

I came across another bugzilla today that has a very similar description. I suspect that the issue here may actually be the same and it does require a small code change.  Care to take a quick look? If it is, we can mark this one as a duplicate.

The other bz is bug 1429624.

thanks,
Brad

Comment 8 Roman Bobek 2017-05-15 05:36:23 UTC
(In reply to Brad Buckingham from comment #7)

Hello Brad,

yes, this BZ is a duplicate of Bug 1429624 and can be closed.

Regards,


-Roman

Comment 9 Brad Buckingham 2017-05-31 19:42:48 UTC

*** This bug has been marked as a duplicate of bug 1429624 ***


Note You need to log in before you can comment on or make changes to this bug.