Bug 1415242 - Import VM dialog does not offer the dropdown list to choose a destination Storage Domain. [NEEDINFO]
Summary: Import VM dialog does not offer the dropdown list to choose a destination Sto...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.9
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Tal Nisan
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 16:22 UTC by Federico Sun
Modified: 2020-02-14 18:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 09:54:19 UTC
oVirt Team: Storage
Target Upstream Version:
tnisan: needinfo? (fsun)


Attachments (Terms of Use)
Import popup (33.08 KB, image/png)
2017-01-22 10:11 UTC, Tal Nisan
no flags Details

Description Federico Sun 2017-01-20 16:22:01 UTC
Created attachment 1242925 [details]
only 'Cluster' and 'CPU profile' dropdown are shown. No dropdown for 'Default Storage Domain'. Also lacks dialog window title/header.

Description of problem:

>When trying to import a VM from Export Domain, the import dialog that comes up does not offer the usual dropdown list to select a destination Storage Domain. 

>If accepting this import, it will go to the Data Master Domain. If Data Master doesn't have enough space, import fails.

~~
Version-Release number of selected component (if applicable):

>rhevm-3.6.9.2-0.1.el6.noarch

~~
How reproducible:

Not sure, so far this seems to be an isolated case.

Steps to Reproduce:
1. Go to Export Domain.
2. Select VM to import.

Actual results:

Cannot choose a destination SD because the dropdown list is no there.

~~
Expected results:

Able to use the dropdown list to choose an appropriate SD with enough free space.

~~
Additional info:

The import dialog also lacks the proper window header which is odd.

Comment 1 Tal Nisan 2017-01-22 10:10:41 UTC
Hi Federico,
The destination storage domain appears when you click on a certain VM from the list and move to the 'Disks' sub tab, see in the attachment.

As for the missing header it doesn't seem to occur in the English version, perhaps a translation missing, can you try and see if it reproduces when running webadmin with English locale?

Comment 2 Tal Nisan 2017-01-22 10:11:25 UTC
Created attachment 1243305 [details]
Import popup


Note You need to log in before you can comment on or make changes to this bug.