Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415244 - New VM dialog doesn't check that disk for VM is created in the same DC as VM itself
Summary: New VM dialog doesn't check that disk for VM is created in the same DC as VM ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 16:28 UTC by jniederm
Modified: 2020-04-01 14:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-01 14:45:02 UTC
oVirt Team: Virt
tjelinek: ovirt-future?
tjelinek: planning_ack?
tjelinek: devel_ack?
tjelinek: testing_ack?


Attachments (Terms of Use)

Description jniederm 2017-01-20 16:28:27 UTC
Description of problem:
If there are more DCs in the engine and new VM with a disk is created and if the VM DC is changed after the create new disk dialog is closed, then new disk for new VM failed to be created since it is being created in DC other than the VM ones.

Version-Release number of selected component (if applicable):
4.2 master, commit 461eb97

How reproducible:
100%

Steps to Reproduce:
1. Let's have 2 DCs with clusters, hosts and storage domains, let's refer to them as A and B
2. Open New VM dialog
3. Fill in some name
4. Select DC A
5. Click "Create" button in General subtab to create new disk for the VM. Make sure that the disk will be created in storage domain corresponding to DC A (as the VM has selected). Confirm the new virtual disk dialog
6. Change the selected DC for VM to B
7. Confirm the New VM dialog

Actual results:
New VM dialog is closed. Error message pops up:
"Cannot add Virtual Disk. The target Data Center does not contain the Virtual Machine."

Expected results:
Both disk and VM are created in the same DC or the problem is validated and user in notified before whole settings of new VM is lost.

Additional info:

Comment 1 Martin Tessun 2017-03-06 10:14:24 UTC
Solution for this one would be to forbid changing the DC/Cluster once a disk or NIC has been added to the VM.
Maybe also some 2-screen wizard that does have a screen for selecting DC and Cluster first before moving on to the next screen for defining the VM.

Comment 2 Michal Skrivanek 2020-03-19 15:41:32 UTC
We didn't get to this bug for more than 2 years, and it's not being considered for the upcoming 4.4. It's unlikely that it will ever be addressed so I'm suggesting to close it.
If you feel this needs to be addressed and want to work on it please remove cond nack and target accordingly.

Comment 3 Michal Skrivanek 2020-04-01 14:45:02 UTC
ok, closing. Please reopen if still relevant/you want to work on it.

Comment 4 Michal Skrivanek 2020-04-01 14:49:46 UTC
ok, closing. Please reopen if still relevant/you want to work on it.


Note You need to log in before you can comment on or make changes to this bug.