Bug 1415314 - ACPI Error AE_AML_PACKAGE_LIMIT
Summary: ACPI Error AE_AML_PACKAGE_LIMIT
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-20 20:37 UTC by Yiannis Panagou
Modified: 2019-01-09 12:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 17:03:44 UTC
Type: Bug


Attachments (Terms of Use)
acpidump (652.18 KB, text/plain)
2017-01-20 20:58 UTC, Yiannis Panagou
no flags Details
dmesg output (71.71 KB, text/plain)
2017-01-20 20:59 UTC, Yiannis Panagou
no flags Details
ACPI dump (389.09 KB, text/plain)
2017-10-11 19:54 UTC, lukaSH
no flags Details
DMESG log (78.23 KB, text/plain)
2017-10-11 19:55 UTC, lukaSH
no flags Details

Description Yiannis Panagou 2017-01-20 20:37:16 UTC
Description of problem:

When startup my laptop return below errors



+0,000112] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000003] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000004] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS01._PLD] (Node ffff9022a70d5780), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000131] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000003] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS02._PLD] (Node ffff9022a70d5fc8), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000334] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000003] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS05._PLD] (Node ffff9022a70d5be0), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000097] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS06._PLD] (Node ffff9022a70d52d0), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000097] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000001] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000003] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS07._PLD] (Node ffff9022a70d5c08), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000096] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS08._PLD] (Node ffff9022a70d5708), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000098] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000001] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS09._PLD] (Node ffff9022a70d5ed8), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000096] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS10._PLD] (Node ffff9022a70d50c8), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000105] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000001] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000003] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS11._PLD] (Node ffff9022a70d5de8), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000096] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS12._PLD] (Node ffff9022a70d5d98), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000098] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS13._PLD] (Node ffff9022a70d5168), AE_AML_PACKAGE_LIMIT (20160422/psparse
[  +0,000095] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000008) is beyond end of object (length 0x1) (20160422/exoparg2-427)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.XPLD] (Node ffff9022a70d72f8), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[  +0,000002] ACPI Error: Method parse/execution failed [\_SB.PCI0.XHC.RHUB.HS14._PLD] (Node ffff9022a70d5ca8), AE_AML_PACKAGE_LIMIT (20160422/psparse

Comment 1 Yiannis Panagou 2017-01-20 20:40:19 UTC
My Kernel version is: 4.9.3-200.fc25.x86_64

Comment 2 Yiannis Panagou 2017-01-20 20:58:03 UTC
Created attachment 1242998 [details]
acpidump

ACPIDUMP

Comment 3 Yiannis Panagou 2017-01-20 20:59:19 UTC
Created attachment 1242999 [details]
dmesg output

Comment 4 Yiannis Panagou 2017-03-02 19:56:29 UTC
Do you have any update??

Comment 5 Justin M. Forbes 2017-04-11 14:32:41 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 6 Justin M. Forbes 2017-04-28 17:03:44 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the 
relevant data from the latest kernel you are running and any data that might have been requested previously.

Comment 7 lukaSH 2017-10-11 19:41:57 UTC
I have the same issues in Fedora 25 and now in Fedora 26. System hang outs, occasionally let say 1 time per 50 boots. Helps only Ctrl+Alt+Del nothing else. I've updated many times Fedora 25 up today and nothing, so I reinstall to new Fedora 26 and have the same. After this message system is hang, cannot do anything, just white characters on black screen.


[    2.388438] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20170531/exoparg2-427)
[    2.388450] ACPI Error: Method parse/execution failed \_SB.PCI0.GFX0._DSM, AE_AML_PACKAGE_LIMIT (20170531/psparse-550)
[    2.388466] ACPI: \_SB_.PCI0.GFX0: failed to evaluate _DSM (0x300b)
[    2.388470] ACPI Warning: \_SB.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[    2.388552] ACPI Warning: \_SB.PCI0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[    2.388649] i915 0000:00:02.0: optimus capabilities: enabled, status dynamic power, 
[    2.388681] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20170531/exoparg2-427)
[    2.388690] ACPI Error: Method parse/execution failed \_SB.PCI0.GFX0._DSM, AE_AML_PACKAGE_LIMIT (20170531/psparse-550)
[    2.388700] ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.GFX0._DSM, AE_AML_PACKAGE_LIMIT (20170531/psparse-550)
[    2.388712] ACPI: \_SB_.PCI0.PEG0.GFX0: failed to evaluate _DSM (0x300b)
[    2.388715] ACPI Warning: \_SB.PCI0.PEG0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[    2.388782] ACPI Warning: \_SB.PCI0.PEG0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)

System = Fedora 26 LXDE
Kernel = 4.13.5-200.fc26.x86_64 #1 SMP
Laptop = Asus K73S
Graphics = Nvidia GeForce GT540M

(In my opinion this is not bug in Fedora bud in kernel driver for Optimus graphics)

Comment 8 lukaSH 2017-10-11 19:54:28 UTC
Created attachment 1337407 [details]
ACPI dump

Comment 9 lukaSH 2017-10-11 19:55:07 UTC
Created attachment 1337408 [details]
DMESG log

Comment 10 lukaSH 2017-10-11 20:04:41 UTC
Let me be clear: system hang outs "occasionally" but if it hang it is unable to work even after restart via Ctrl+Alt+Del. So after Fedora 25 and now Fedora 26 I must install Ubuntu to access my files.


Note You need to log in before you can comment on or make changes to this bug.