Bug 1415363 - Key mapping is working incorrectly in RDP connection to windows 8
Summary: Key mapping is working incorrectly in RDP connection to windows 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vinagre
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-21 06:20 UTC by ilya
Modified: 2017-08-01 18:41 UTC (History)
2 users (show)

Fixed In Version: vinagre-3.22.0-2.el7
Doc Type: Bug Fix
Doc Text:
Cause: Certain keys were wrongly interpreted by Vinagre. Consequence: Written text was different from what user expected. Fix: Handling of extended scancodes of such keys has been fixed. Result: Text written by the user corresponds to the expected text.
Clone Of:
Environment:
Last Closed: 2017-08-01 18:41:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 769025 0 Normal RESOLVED Extended RDP scancodes are not handled properly 2020-11-10 16:12:27 UTC
Red Hat Product Errata RHBA-2017:2005 0 normal SHIPPED_LIVE vinagre bug fix and enhancement update 2017-08-01 18:11:40 UTC

Description ilya 2017-01-21 06:20:10 UTC
Description of problem:
Key mapping is working incorrectly in RDP connection to windows 8;

Version-Release number of selected component (if applicable):
hmm, maybe my russian keymap on my rhel is cause this bug.

How reproducible:


Steps to Reproduce:
1. Connect to windows 8 by rdp.
2. Open windows notepad and type some text.
3. Press left button

Actual results:
"4" symbol is typed 

Expected results:
cursor should be moved left

Additional info:
down arrow -> "2" is typed
up urrow -> "8"
left arrow -> "4"
delete button -> "."
escape -> i do not understand, but something is wrong

Comment 2 Marek Kašík 2017-02-01 10:49:55 UTC
Hi,

thank you for this report. This bug has been fixed upstream in https://git.gnome.org/browse/vinagre/commit/?id=69acae5330c848cb7bf4094ebce34ccad798c6ca. The patch fixes the bug also in Red Hat Enterprise Linux 7. I'm proposing to fix this bug in upcoming minor release.

Comment 7 ilya 2017-03-01 16:59:00 UTC
And when it will be fixed?

Comment 8 Marek Kašík 2017-03-02 09:46:10 UTC
I've proposed the fix for 7.4 so if everything goes well then you will find it in 7.4 release of Red Hat Enterprise Linux.

Comment 9 ilya 2017-03-02 14:21:48 UTC
And when 7.4 will be released? I think this is a critical bug: i can't work with vinagre.

Comment 10 Marek Kašík 2017-03-02 14:34:12 UTC
I'm sorry, I can not comment on when the release will be available.

Comment 11 ilya 2017-03-02 15:11:31 UTC
May be you have any useful answers for my questions? Do i need to wait for weeks, or months, or years?

Comment 12 Marek Kašík 2017-03-02 15:33:06 UTC
You can approach our support and ask them about this.

Comment 13 Bohdan Milar 2017-06-01 13:13:06 UTC
Tested on vinagre-3.22.0-8.el7.x86_64
Problem did not appear.

Comment 14 errata-xmlrpc 2017-08-01 18:41:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2005


Note You need to log in before you can comment on or make changes to this bug.