Bug 1415379 - Bluetooth not working after a while on Intel Corporation Wireless 8260 (rev 3a)
Summary: Bluetooth not working after a while on Intel Corporation Wireless 8260 (rev 3a)
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-21 11:19 UTC by Daniel Rindt
Modified: 2019-07-22 14:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 13:19:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Rindt 2017-01-21 11:19:02 UTC
Description of problem:
Since the last update of the system the bluetooth mouse stops working after login and starting my webbrowser. 


Version-Release number of selected component (if applicable):
iwl7260-firmware-25.30.13.0-69.fc25.noarch
kernel-4.9.4-201.fc25.x86_64

How reproducible:
Simply login to your account in gnome, opening a browser let them request a page. Mouse pointer become laggy and finally after a few more seconds it stops fully from moving.

Steps to Reproduce:
1. Login into your account, move the mouse, no issues
2. Open any webbrowser for traffic on wireless
3. HID device stops working after a maximum of 10 seconds

Actual results:
Unable to use the bluetooth pointer. Also BT Audio isn't working. I assume that the whole bluetooth isn't working anymore.

Expected results:
Bluetooth should work.

Additional info:
I can remember at the beginning 2016 there was a lot of issues with bluetooth coexistence with wifi. Since both use the 2.4Ghz band for communication. So far i know there is a flag for the iwlwifi module bt_coex_active which i have played with. Without success this time. In the time ago i used the flag to set that i use both wifi and bluetooth. The option become a default and so the option i had no longer to set to enabled. But for now seems that this feature is completely broken. I had no succeess by undoing my dnf update.
I wasn't able to select the proper component, so i decided to use the generic one. The real package which contains the firmware is iwl7260-firmware.

Comment 1 Daniel Rindt 2017-02-28 13:19:47 UTC
In the meantime the mouse works again, but isn't usable. The mouse pointer stutters and some movements are not influencing the pointer. Slow down random
makes the mouse unusable. Since i can't reproduce the issue for other bt devices i guess the issue on this layer is solved.

Comment 2 Chris Bredesen 2019-07-22 14:57:50 UTC
Hi Daniel,

I'm diagnosing a similar issue with my BT mouse setup (I'd for years been using Logi/MS proprietary wireless with dongle). The symptom I have is that at seemingly random times, my BT mouse (Satechi M1) will become very laggy and "disconnected" feeling. It works, but is painful to use. Toggling BT off/on in the UI or via command line (`systemctl restart bluetooth.service`) clears the issue up. 

Does this sound related to anything you saw? I wanted to ask before filing a new bug.

bluez-5.50-8.fc30.x86_64
kernel-5.1.18-300.fc30.x86_64


Note You need to log in before you can comment on or make changes to this bug.