Bug 1415391 - scim-pinyin does not add smart pinyin as an input option
Summary: scim-pinyin does not add smart pinyin as an input option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-pinyin
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-21 12:50 UTC by art
Modified: 2017-02-13 22:47 UTC (History)
3 users (show)

Fixed In Version: scim-pinyin-0.5.92-9.fc25 scim-pinyin-0.5.92-9.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 04:22:10 UTC
Type: Bug


Attachments (Terms of Use)

Description art 2017-01-21 12:50:13 UTC
Description of problem:
smart pinyin doesn't get listed for selection in IMEngine Global Setup menu

Version-Release number of selected component (if applicable):
scim-pinyin 0.5.92-8.fc24

How reproducible:
always 

Steps to Reproduce:
1.fresh net install of fedora 25 with only window managers, up to date
2.install scim, scim-tables, scim-tables-russian, scim-pinyin 
3.change the input method to  scim by im-chooser pulled with scim by default
4.log out, log back in (or even reboot)

Actual results:
only Russian and Other are listed as options in IMEngine Global Setup menu. Smart pinyin is listed as a separate menu below, but it's just for configuring, not for adding it to as an input methods.
Default Control+space triger does change between russian and default english keyboard.
installing scim-bridge, scim-bridge-gtk, scim-gtk on top of it doesn't change things


Expected results:
Smart pinyin should be listed as a method for Chinese input in IMEngine Global Setup menu.

Additional info:

Comment 1 art 2017-01-21 13:03:09 UTC
issuing scim -d from the terminal with scim not being the default im method doesn't show any errors, journalctl | tail -n 20  (scim -d was launched on a fresh boot) doesn't show any SCIM errors. will be more then happy to provide any additional info. Thanks!

Comment 2 Peng Wu 2017-01-22 01:47:00 UTC
Reported Upstream: https://github.com/scim-im/scim-pinyin/issues/1

Comment 3 art 2017-01-22 02:59:40 UTC
(In reply to Peng Wu from comment #2)
> Reported Upstream: https://github.com/scim-im/scim-pinyin/issues/1

Thanks!

Comment 4 art 2017-01-26 07:55:10 UTC
as a follow up i did manage to compile scim and scim-pinyin from upstream github. It doesn't result in an abnormal behaviour mentioned above. On contrary it all functions as expected. Here are the steps i took to compile it:

  1  sudo dnf groupinstall "C Development Tools and Libraries"  
  2  sudo dnf install git gettext-devel libtool-ltdl-devel intltool
  3  sudo dnf install xorg-x11-server-devel
  4  sudo dnf install gtk2-devel
  5  sudo dnf install gtk3-devel
  6  sudo dnf install qt4-devel
  7  git clone https://github.com/scim-im/scim
  8  cd scim/
  9  ./bootstrap 
  10 ./configure $enable_shared $enable_static $enable_config_socket $enable_frontend_x11 $enable_frontend_socket $enable_gtk_utils $enable_x11_utils $USE_GTK_VERSION $enable_setup_ui $enable_panel_gtk $enable_tray_icon $GTK2_IM_MODULEDIR  $GTK3_IM_MODULEDIR $QT4_IM_MODULEDIR $enable_im_agent $enable_gtk2_immodule $enable_gtk3_immodule $enable_qt4_immodule
  11  make
  11  sudo make install
  12  cd ~
  13  git clone https://github.com/scim-im/scim-pinyin
  14  cd scim-pinyin/
  15  ./bootstrap
  16  export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
  17  ./configure
  18  make
  19  sudo make install

compiled this way scim-setup does show smart piyin on every boot, typing and changing between the input methods does work as expected. So could the initial bug be caused by some sort of packaging issue?

Hope it's hepfull, will be glad to provide further info and assistance,
Best wishes,
Artem

Comment 5 Peng Wu 2017-02-03 08:36:49 UTC
Thanks very much for the help!

New scim-pinyin package is built, please try it. :)

Comment 6 Fedora Update System 2017-02-03 08:40:08 UTC
scim-pinyin-0.5.92-9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c62ac3a3c6

Comment 7 Fedora Update System 2017-02-03 08:40:17 UTC
scim-pinyin-0.5.92-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-648c3dd787

Comment 8 art 2017-02-03 15:04:49 UTC
Did get to try the fc25 version and from the looks of (~10 minutes run) it works just brilliantly!  +1'd it accordingly on the bodhi page. Once again thanks a lot for your time and hardwork! And sorry i was too late to remember of the upcoming lunar new year with my comment :) belated 鸡年大吉!

Comment 9 Fedora Update System 2017-02-03 22:55:04 UTC
scim-pinyin-0.5.92-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-648c3dd787

Comment 10 Fedora Update System 2017-02-03 23:50:28 UTC
scim-pinyin-0.5.92-9.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c62ac3a3c6

Comment 11 Peng Wu 2017-02-04 01:42:36 UTC
Thanks! :)

Comment 12 Fedora Update System 2017-02-09 04:22:10 UTC
scim-pinyin-0.5.92-9.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-02-13 22:47:44 UTC
scim-pinyin-0.5.92-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.