Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415399 - xorg-x11 random crashes a couple of times per day!
Summary: xorg-x11 random crashes a couple of times per day!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-21 14:34 UTC by Ali Akcaagac
Modified: 2017-01-29 10:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-29 10:17:37 UTC
Type: Bug


Attachments (Terms of Use)
coredumpctl output (3.32 KB, text/plain)
2017-01-21 14:34 UTC, Ali Akcaagac
no flags Details
full backtrace (10.96 KB, text/plain)
2017-01-23 14:27 UTC, Ali Akcaagac
no flags Details

Description Ali Akcaagac 2017-01-21 14:34:25 UTC
Created attachment 1243163 [details]
coredumpctl output

I've been getting random crashes a couple of times per day with latest xorg.* mesa.* (since a around 2 weeks now) and don't really know where to put this report.

Current situation:

I've been running the latest Fedora 25 updates together with Xfce 4.x.

The system is a Lenvo E325 Notebook with a Radeon HD graphics APU installed (APU E-450). The radeon driver is being used (iirc).

An external Monitor is connected via VGA and usually is always turned on.

Under unknown circumstances every now and then the entire xwindow system crashes (no reboot of the system, just crashing xwindow system), trashes all open and running programs, loading up lightdm after a while again so you can re-login. From that point on you can operate the system normally again.

Sometimes ... when this happenes ... it's not possible to shutdown the Notebook anymore because once the xwindow system gets closed a picture with random artifact GPU memory content shows up and then locks up the entire Notebook. You need to press power-off to shut the Notebook down.

The crashes aren't the problem, because it's always possible to recover from that crash and manually unmount critical drives. Sadly all work done by open programs (like spreadsheets, editors) etc. are totally lost.

Please find attached a coredump output (text).

Further information:

bash-4.3$ rpm -qa | grep -i "^xorg" | sort
xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25.x86_64
xorg-x11-drv-evdev-2.10.5-1.fc25.x86_64
xorg-x11-drv-fbdev-0.4.3-25.fc25.x86_64
xorg-x11-drv-intel-2.99.917-26.20160929.fc25.x86_64
xorg-x11-drv-libinput-0.23.0-2.fc25.x86_64
xorg-x11-drv-nouveau-1.0.13-1.fc25.x86_64
xorg-x11-drv-qxl-0.1.4-10.20160929gite13d28ee.fc25.x86_64
xorg-x11-drv-synaptics-1.9.0-1.fc25.x86_64
xorg-x11-drv-vesa-2.3.2-25.fc25.x86_64
xorg-x11-font-utils-7.5-32.fc25.x86_64
xorg-x11-server-common-1.19.1-2.fc25.x86_64
xorg-x11-server-utils-7.7-20.fc25.x86_64
xorg-x11-server-Xorg-1.19.1-2.fc25.x86_64
xorg-x11-utils-7.5-21.fc24.x86_64
xorg-x11-xauth-1.0.9-5.fc24.x86_64
xorg-x11-xinit-1.3.4-13.fc25.x86_64
xorg-x11-xkb-utils-7.7-17.fc24.x86_64
-bash-4.3$ 

-bash-4.3$ rpm -qa | grep -i "^mesa" | sort
mesa-dri-drivers-13.0.3-1.fc25.x86_64
mesa-filesystem-13.0.3-1.fc25.x86_64
mesa-libEGL-13.0.3-1.fc25.x86_64
mesa-libgbm-13.0.3-1.fc25.x86_64
mesa-libGL-13.0.3-1.fc25.x86_64
mesa-libglapi-13.0.3-1.fc25.x86_64
mesa-libGLES-13.0.3-1.fc25.x86_64
mesa-libGLU-9.0.0-10.fc24.x86_64
mesa-libwayland-egl-13.0.3-1.fc25.x86_64
-bash-4.3$ 

-bash-4.3$ rpm -qa | grep -i "^kernel" | sort
kernel-4.9.4-201.fc25.x86_64
kernel-core-4.9.4-201.fc25.x86_64
kernel-modules-4.9.4-201.fc25.x86_64
-bash-4.3$

Comment 1 Ali Akcaagac 2017-01-23 14:27:52 UTC
Created attachment 1243608 [details]
full backtrace

I was able to catch another coredump and created a full bt from it.

Please find attached a full backtrace of the reported issue.

Comment 2 Ali Akcaagac 2017-01-23 14:36:32 UTC
Looks like an driver issue within the ati driver package ? Tried re-assigning, hope it worked.

Comment 3 Ali Akcaagac 2017-01-29 10:17:37 UTC
The issue is gone with recent kernel and mesa updates. Must've been a regression. If this issue shows up again, I will re-open a new bugreport.


Note You need to log in before you can comment on or make changes to this bug.