Bug 141541 - TERM=xterm at GNOME terminal causes a strange line behaviour with irssi
TERM=xterm at GNOME terminal causes a strange line behaviour with irssi
Status: CLOSED DUPLICATE of bug 139294
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 16:36 EST by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-12-01 16:36:39 EST
Description of problem:
If I want to chat using the textbased chat client irssi at a GNOME
terminal having the default setting TERM=xterm, I get missing, 
double or hopping lines inside the terminal after some time. It's 
really strange and very hard to describe. If I start irssi using 
TERM=linux, I don't have that problem. 

So I guess the problem is either ncurses (where I assigned it to) 
and/or GNOME terminal related. The problem came up with Fedora Core 
3 the first time.

Version-Release number of selected component (if applicable):
ncurses-5.4-13

How reproducible:
Most of the time, see below.

Steps to Reproduce:
1. Install irssi (a textbased chat client)
2. Start it (using the default TERM=xterm at a GNOME terminal)
3. Chat with some people ;-)
4. Find missing lines or double lines or strange hopping things after
   1-5 screens of text.
[5. Try the same using TERM=linux and see the difference]

Actual results:
Hopping lines etc.

Expected results:
Normal behaviour as it was a long time ago...
Comment 1 Thomas E. Dickey 2004-12-04 12:25:45 EST
This sounds like the scrolling issue mentioned in #122815
(the issue is that gnome-terminal doesn't implement the
ECMA SD/SU controls in xterm's terminfo).
Comment 2 Matthew S. Hallacy 2004-12-21 18:48:38 EST
Bug #139294 is a dupe of this one.
Comment 3 Petr Rockai 2005-02-17 09:29:27 EST

*** This bug has been marked as a duplicate of 139294 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.