Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415441 - AttributeError: 'NEVRA' object has no attribute '_has_just_name'
Summary: AttributeError: 'NEVRA' object has no attribute '_has_just_name'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 03:01 UTC by Wesley Tanaka
Modified: 2017-01-24 03:48 UTC (History)
5 users (show)

Fixed In Version: dnf-1.1.10-4.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 03:48:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Wesley Tanaka 2017-01-22 03:01:16 UTC
Description of problem:

dnf install crashes with error AttributeError: 'NEVRA' object has no attribute '_has_just_name' -- I am not sure if this is an issue with dnf or with the fedora docker image, which I am using.

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:

Trigger either of these travis builds:
https://travis-ci.org/wtanaka/ansible-role-vagrant/jobs/194099850
https://travis-ci.org/wtanaka/ansible-role-slack/jobs/194099715


Actual results:

Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.5/site-packages/dnf/cli/cli.py", line 1099, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.5/site-packages/dnf/cli/commands/install.py", line 89, in run
    self.base.install(pkg_spec, strict=strict)
  File "/usr/lib/python3.5/site-packages/dnf/base.py", line 1432, in install
    sltrs = subj.get_best_selectors(self.sack)
  File "/usr/lib/python3.5/site-packages/dnf/subject.py", line 163, in get_best_selectors
    return [self.get_best_selector(sack, forms)]
  File "/usr/lib/python3.5/site-packages/dnf/subject.py", line 126, in get_best_selector
    if nevra._has_just_name():
AttributeError: 'NEVRA' object has no attribute '_has_just_name'



Expected results:

DNF does not throw exception

Additional info:

Comment 1 Igor Gnatenko 2017-01-22 08:57:00 UTC
which version of dnf and hawkey you have?

Comment 2 Fedora Update System 2017-01-22 09:13:01 UTC
dnf-1.1.10-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6abb5726f7

Comment 3 Fedora Update System 2017-01-23 01:48:10 UTC
dnf-1.1.10-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6abb5726f7

Comment 4 masanari iida 2017-01-24 00:27:25 UTC
I had this symptom after dnf update to dnf-1.1.10-3.fc24.

I have updated following RPMS (download manually from koji)
python3-hawkey-0.6.3-6.1.fc24
hawkey-0.6.3-6.1.fc24

Then problem fixed.
Now I can use dnf to download RPMs without error.

I didn't test dnf-1.1.10-4.fc24.
If you encounter this symptom, you can not download individual RPMs
from repo using dnf. So it may be difficult to download a test RPM using dnf.

Comment 5 masanari iida 2017-01-24 01:22:55 UTC
rpcbind-0.2.3-15.rc2.fc24.x86_64              Tue Jan 24 09:21:10 2017

python3-hawkey-0.6.3-6.1.fc24.x86_64          Tue Jan 24 09:15:50 2017
hawkey-0.6.3-6.1.fc24.x86_64                  Tue Jan 24 09:15:50 2017

sheepdog-1.0.1-2.fc24.x86_64                  Sat Jan 21 18:10:37 2017
python3-dnf-1.1.10-3.fc24.noarch              Sat Jan 21 18:10:37 2017
perl-open-1.10-366.fc24.noarch                Sat Jan 21 18:10:37 2017
perl-IO-1.35-366.fc24.x86_64                  Sat Jan 21 18:10:37 2017
dnf-yum-1.1.10-3.fc24.noarch                  Sat Jan 21 18:10:37 2017
dnf-conf-1.1.10-3.fc24.noarch                 Sat Jan 21 18:10:37 2017
dnf-1.1.10-3.fc24.noarch                      Sat Jan 21 18:10:37 2017
 
vim-minimal-8.0.194-1.fc24.x86_64             Sat Jan 21 18:09:29 2017
snapper-libs-0.4.1-1.fc24.x86_64              Sat Jan 21 18:09:29 2017

According to my "rpm -qa --last",  I have updated dnf-yum, dnf-conf 
and python3-dnf RPMs at one time.
But I didn't include hawkey and python3-hawkey.
dnf didn't pull these 2 as dependency.
I understand this is the reason why I encountered the issue.

If my understanding is correct, the dnf needs to have dependency with hawkey.

Comment 6 Fedora Update System 2017-01-24 03:48:49 UTC
dnf-1.1.10-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.