Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415455 - recipe for target 'install-ws_pluginLTLIBRARIES' failed
Summary: recipe for target 'install-ws_pluginLTLIBRARIES' failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Privoznik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 07:54 UTC by jean-christophe manciot
Modified: 2017-06-05 11:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 11:46:04 UTC


Attachments (Terms of Use)

Description jean-christophe manciot 2017-01-22 07:54:13 UTC
Description of problem:
----------------------
Cannot install libvirt when built from sources with tag v3.0.0

How reproducible:
----------------
Building with:
- branch=master
- tag=v3.0.0
- release_number=3.0.0
- os_version=16.10

        echo --------
        echo Cleaning
        echo --------
        cd git-libvirt
        git-reset-clean-pull-checkout.sh $branch $tag

        echo -----------
        echo Configuring
        echo -----------
        export CLEAN_SUBMODULE=1
        export NOCONFIGURE=yes
        ./autogen.sh

        ./configure   --build=x86_64-pc-linux-gnu \
                      --with-openssl \
                      --with-systemd-daemon \
                      --with-numactl \
                      --with-numad \
                      --with-default-editor=gedit \
                      --without-xen --without-xen-inotify --without-xenapi --without-libxl \
                      --enable-expensive-tests \
                      --enable-test-coverage \
                      --disable-nls \
                      --enable-static \
                      --enable-shared \
                      --prefix=/usr --sysconfdir=/etc --localstatedir=/var

        echo ---------
        echo Compiling
        echo ---------
        make

        echo ---------
        echo "Building"
        echo ---------
        echo '' | checkinstall -D --install=no --pkgname="libvirt" --pkgversion="${release_number}" --pkgrelease="${os_version}" --pkgarch="amd64" --pkggroup="libs" --maintainer="Jean-Christophe Manciot \<manciot.jeanchristophe@gmail.com\>" --requires="glusterfs-common,libacl1,libapparmor1,libasn1-8-heimdal,libattr1,libaudit1,libaugeas0,libavahi-client3,libavahi-common3,libblkid1,libboost-iostreams1.61.0,libboost-random1.61.0,libboost-system1.61.0,libboost-thread1.61.0,libc6,libcap-ng0,libcomerr2,libcurl3-gnutls,libdbus-1-3,libdevmapper1.02.1,libffi6,libfuse2,libgcc-6-dev,libgcrypt,libgmp10,libgnutls30,libgpg-error,libgssapi3-heimdal,libgssapi-krb5-2,libhcrypto4-heimdal,libheimbase1-heimdal,libheimntlm0-heimdal,libhogweed4,libhx509-5-heimdal,libidn11,libk5crypto3,libkeyutils1,libkrb5-26-heimdal,libkrb5-3,libkrb5support0,libldap-2.4-2,liblzma5,libnetcf1,libnettle6,libnl-3-200,libnl-genl-3-200,libnl-route-3-200,libnuma1,libobasis5.2-core,libp11-kit0,libparted2,libpcap,libpciaccess0,libpcre3,librados2,librbd1,libreadline7,libroken18-heimdal,librtmp1,libsanlock-client1,libsasl2-2,libselinux1,libsqlite3-0,libssh,libssh-4,libssl1.0.0,libssl1.1,libstdc++6,libsystemd0,libtasn1-6,libtinfo5,libudev1,libuuid1,libvirt0,libvirt-daemon,libvirt-daemon-system,libwind0-heimdal,libxml2,libxslt1.1,libyajl2,pristine-tar,zlib1g" --conflicts="dhcp-helper" --replaces="libvirt0,libvirt-bin,libvirt-clients,libvirt-daemon,libvirt-daemon-system,libvirt-dev,libvirt-doc"

Actual results:
--------------
...
/bin/mkdir -p '/usr/bin'
  /bin/bash ../libtool   --mode=install /usr/bin/install -c virsh virt-admin virt-login-shell virt-host-validate '/usr/bin'
libtool: install: /usr/bin/install -c .libs/virsh /usr/bin/virsh
libtool: install: /usr/bin/install -c .libs/virt-admin /usr/bin/virt-admin
libtool: install: /usr/bin/install -c virt-login-shell /usr/bin/virt-login-shell
libtool: install: /usr/bin/install -c .libs/virt-host-validate /usr/bin/virt-host-validate
 /bin/mkdir -p '/usr/bin'
 /usr/bin/install -c virt-xml-validate virt-pki-validate '/usr/bin'
 /bin/mkdir -p '/usr/libexec'
 /usr/bin/install -c libvirt-guests.sh '/usr/libexec'
 /bin/mkdir -p '/usr/sbin'
 /usr/bin/install -c virt-sanlock-cleanup '/usr/sbin'
 /bin/mkdir -p '/etc/libvirt'
 /usr/bin/install -c -m 644 virt-login-shell.conf '/etc/libvirt'
/bin/mkdir -p /etc/sysconfig
/usr/bin/install -c -m 644 ./libvirt-guests.sysconf \
  /etc/sysconfig/libvirt-guests
/bin/mkdir -p /usr/lib/systemd/system
/usr/bin/install -c -m 644 libvirt-guests.service \
  /usr/lib/systemd/system/libvirt-guests.service
 /bin/mkdir -p '/usr/share/man/man1'
 /usr/bin/install -c -m 644 virt-pki-validate.1 virt-xml-validate.1 virsh.1 virt-admin.1 virt-login-shell.1 virt-host-validate.1 '/usr/share/man/man1'
 /bin/mkdir -p '/usr/share/man/man8'
 /usr/bin/install -c -m 644 virt-sanlock-cleanup.8 '/usr/share/man/man8'
 /bin/mkdir -p '/usr//usr/lib/x86_64-linux-gnu/wireshark/plugins/2.2.3'
/bin/mkdir: cannot create directory '/usr//usr': No such file or directory
Makefile:2433: recipe for target 'install-ws_pluginLTLIBRARIES' failed
make[3]: *** [install-ws_pluginLTLIBRARIES] Error 1

Additional info:
---------------
Ubuntu 16.10 4.8
bash 4.4

Comment 1 jean-christophe manciot 2017-01-22 07:56:39 UTC
No such issue when built with any previous stable v2.x tag with the exact same script in the exact same environment.

Comment 2 Michal Privoznik 2017-05-22 11:15:12 UTC
Jean,

what's the wireshark version? Also, what's the content of /usr/lib64/pkgconfig/wireshark.pc?

Comment 3 jean-christophe manciot 2017-06-05 11:22:07 UTC
It used to be 2.2.3 at the time of the build, now it is 2.2.7.

There is no "/usr/lib64/pkgconfig/wireshark.pc", but "/usr/lib/x86_64-linux-gnu/pkgconfig/wireshark.pc" contents are now (only the version has changed since the last build):
prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}//usr/lib/x86_64-linux-gnu
includedir=${prefix}/include
sharedlibdir=${libdir}
plugindir=${libdir}/wireshark/plugins/2.2.7

Name: Wireshark
Description: Network Packet Dissection Library
Version: 2.2.7

Requires: glib-2.0, gmodule-2.0, gthread-2.0
Libs: -L${libdir} -lwireshark
Cflags: -I${includedir}/wireshark

Comment 4 Michal Privoznik 2017-06-05 11:46:04 UTC
(In reply to jean-christophe manciot from comment #3)
> It used to be 2.2.3 at the time of the build, now it is 2.2.7.
> 
> There is no "/usr/lib64/pkgconfig/wireshark.pc", but
> "/usr/lib/x86_64-linux-gnu/pkgconfig/wireshark.pc" contents are now (only
> the version has changed since the last build):
> prefix=/usr
> exec_prefix=${prefix}
> libdir=${exec_prefix}//usr/lib/x86_64-linux-gnu
> includedir=${prefix}/include
> sharedlibdir=${libdir}
> plugindir=${libdir}/wireshark/plugins/2.2.7

This is the problem. $prefix is set to "/usr" and so is $exec_prefix. Therefore $libdir (where libvirt tries to install the dissector) is "/usr//usr/lib/...". This is not a libvirt bug. Fix your wireshark installation and you should be all set.


Note You need to log in before you can comment on or make changes to this bug.