Bug 1415463 - openshift-jvm can't open User -> Preference
Summary: openshift-jvm can't open User -> Preference
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alexandre Kieling
QA Contact: Peng Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 09:17 UTC by Peng Li
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Link to Preferences page is not present on the top tollbar Consequence: User cannot change preferences Fix: Add link to Preferences page Result: User can change preferences
Clone Of:
Environment:
Last Closed: 2017-04-12 19:10:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Peng Li 2017-01-22 09:17:34 UTC
Description of problem:
In the openshift-jvm console on a Java application, click the upper right corner User, should show link for 'Preference', but it does not display, so user can't check modify the preferences.

Version-Release number of selected component (if applicable):
openshift v3.5.0.7+390ef18
jvm

How reproducible:
always

Steps to Reproduce:
1. Create a Java application
2. open the openshift console and find the pod  
3. open the "Java Console" on the pod
4. click the User and expect show 'Preference'

Actual results:
Link does not show

Expected results:
User should be able to see the link and modify their preference.

Additional info:
This is a regression issue, it works well in OCP 3.4.0

Comment 2 Alexandre Kieling 2017-01-31 11:12:36 UTC
Fix available in openshift-jvm v1.1.3.
Note: Took the opportunity to upgrade the PatternFly dependency to the latest 3.x version. It pulls other dependencies, such as bootstrap libraries.

Comment 3 Alexandre Kieling 2017-02-01 23:00:22 UTC
Fixed issue with CRLF line breaks in style.css file.
Please use openshift-jvm v1.1.4.

Comment 4 Jessica Forrester 2017-02-02 14:51:15 UTC
Merged into origin-web-console https://github.com/openshift/origin-web-console/pull/1214

Comment 5 Troy Dawson 2017-02-03 22:44:36 UTC
This has been merged into ocp and is in OCP v3.5.0.16 or newer.

Comment 6 Peng Li 2017-02-04 07:01:37 UTC
This UI could be opened, and function under it works well.

openshift v3.5.0.16+a26133a
jvm Version: 1.1.4

Comment 8 errata-xmlrpc 2017-04-12 19:10:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.