Bug 1415466 - Failed with azureDisk dynamic provisioning
Summary: Failed with azureDisk dynamic provisioning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.5.0
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: hchen
QA Contact: Wenqi He
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 09:40 UTC by Wenqi He
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Azure provisioner not enabled Consequence: Failed to provision Axure disks Fix: Enable Azure provisioner Result: Able to provision Azure disks
Clone Of:
Environment:
Last Closed: 2017-04-12 19:10:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Origin (Github) 12756 0 None None None 2017-02-01 18:32:15 UTC
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Wenqi He 2017-01-22 09:40:35 UTC
Description of problem:
Try azure disk dynamic provision with storage class on 3.5 failed

Version-Release number of selected component (if applicable):
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4


How reproducible:
Always

Steps to Reproduce:
1. Create a storage class
oc create -f https://raw.githubusercontent.com/weherdh/v3-testfiles/azsc/persistent-volumes/azure/azsc-LRS.yaml
2. Create a pvc
oc create -f https://raw.githubusercontent.com/weherdh/v3-testfiles/azsc/persistent-volumes/azure/azpvc-sc.yaml
3. Check pvc status

Actual results:
$ oc get storageclass
NAME      TYPE
lrs       kubernetes.io/azure-disk 

$ oc get pvc
NAME      STATUS    VOLUME    CAPACITY   ACCESSMODES   AGE
azclaim   Pending                                      11m

$ oc describe pvc azclaim
Name:		azclaim
Namespace:	wehe
StorageClass:	lrs
Status:		Pending
Volume:		
Labels:		<none>
Capacity:	
Access Modes:	
Events:
  FirstSeen	LastSeen	Count	From				SubObjectPath	Type		Reason			Message
  ---------	--------	-----	----				-------------	--------	------			-------
  11m		7s		49	{persistentvolume-controller }			Warning		ProvisioningFailed	no volume plugin matched


Expected results:
There should be a dynamic PV created for this claim

Additional info:
Master.log:
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623765    1063 pv_controller_base.go:579] storeObjectUpdate: adding claim "wehe/azclaim", version 47256
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623797    1063 pv_controller.go:192] synchronizing PersistentVolumeClaim[wehe/azclaim]: phase: Pending, bound to: "", bindCompleted: false, boundByController: false
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623808    1063 pv_controller.go:216] synchronizing unbound PersistentVolumeClaim[wehe/azclaim]: no volume found
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623814    1063 pv_controller.go:1201] provisionClaim[wehe/azclaim]: started
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623826    1063 pv_controller.go:1397] scheduleOperation[provision-wehe/azclaim[fc5e307e-e076-11e6-a4e7-000d3a138657]]
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623844    1063 pv_controller.go:1220] provisionClaimOperation [wehe/azclaim] started, class: "lrs"
Jan 22 15:47:12 wehe-master atomic-openshift-master: I0122 15:47:12.623902    1063 pv_controller.go:1225] error finding provisioning plugin for claim wehe/azclaim: no volume plugin matched

Comment 1 hchen 2017-02-01 17:21:15 UTC
fix at https://github.com/openshift/origin/pull/12756

Comment 2 Troy Dawson 2017-02-03 22:34:14 UTC
This has been merged into ocp and is in OCP v3.5.0.16 or newer.

Comment 3 Wenqi He 2017-02-04 02:49:32 UTC
Tested on below version:
openshift v3.5.0.16+a26133a
kubernetes v1.5.2+43a9be4

[wehe@dhcp-136-45 octest]$ oc get pvc
NAME      STATUS    VOLUME                                     CAPACITY   ACCESSMODES   AGE
azpvc     Bound     pvc-e4ab8255-ea83-11e6-93d7-000d3a17665e   1Gi        RWO           5s


This bug is fixed, thanks.

Comment 5 errata-xmlrpc 2017-04-12 19:10:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.