Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415468 - kernel 4.9.4-100 "broke" network stack
Summary: kernel 4.9.4-100 "broke" network stack
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 09:56 UTC by Davide Corrado
Modified: 2019-01-09 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-18 21:00:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Davide Corrado 2017-01-22 09:56:03 UTC
Description of problem:
the new kernel has issues with the network stack on my system. the network works for a minute or so, than no packets reach asny host at all (default gw included)

Version-Release number of selected component (if applicable):
kernel 4.9.4-100

How reproducible:
boot into 4.9.4-100.
motherboard gigabyte f2a88x-dh3, a10 cpu, 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)

Steps to Reproduce:
1. just boot and waith a minute or so
2.
3.

Actual results:
network broken

Expected results:
network works

Additional info:
the previous 4.8 kernel works

Comment 1 Jürgen Markmann 2017-01-25 19:30:53 UTC
I had exactly the same problem with a similar WiFi Adapter. Maybe this helps solving the problem:

OS: Fedora 25, 64bit
Hardware: Asus PCE-N15 (it's a PCIe adapter)


As long as I boot an old 4.8.x kernel, WiFi works. If I boot a 4.9.x kernel, my WiFi fails after approximately one minute. iwconfig still states that there is connection to the access point. ifconfig shows the corresponding network with assigned IP address. But I cannot get one bit through the connection. Even a simple ping fails. The loaded kernel module for the card is rtl8192ce.

It seems that the implentation of the power safe mode is buggy (I found some hints in the net).

The following workaround I found in a forum which works excellently in my case:

Disable power safe of rtl8192ce when loaded. I created a conf file for modprobe /etc/modprobe.d/rtl8192ce.conf with the following entry:

options rtl8192ce ips=0 fwlps=0

After unload/load of rtl8192ce or a reboot, WiFi was working also with 4.9 kernels. Maybe you should disable power safe mode it by default until it's correctly implemented.

Comment 2 Dmitry Stremkouski 2017-01-25 22:53:32 UTC
Duplicate for 1415339(https://bugzilla.redhat.com/show_bug.cgi?id=1415339)

Comment 3 Davide Corrado 2017-02-01 08:23:47 UTC
the issue still exists with latest 4.9 kernels so far.
in the past (I mean at least one year ago) i was using these options for the given module:

# Disable powersaving
options rtl8192ce ips=0

# WARNING! Do not enable this shit.
#          It causes bugs.
options rtl8192ce fwlps=0

# Use software control instead
options rtl8192ce swlps=1


then, I discovered that they weren't needed anymore, so I forgot. Reading your reply brought this back. thanks.

Comment 4 Dmitry Stremkouski 2017-02-02 20:03:37 UTC
Thank you guys, that worked for me as well.

Comment 5 Justin M. Forbes 2017-04-11 15:00:54 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 6 Jürgen Markmann 2017-04-18 20:17:19 UTC
With the current kernel (4.10.9-100), WiFi also works in my case without the extra arguments.

Comment 7 Justin M. Forbes 2017-04-18 21:00:07 UTC
Excellent, going to close this, if others are still seeing the issue with a 4.10 kernel, please reopen.


Note You need to log in before you can comment on or make changes to this bug.