Bug 1415496 - rpcbind fails at boot
Summary: rpcbind fails at boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 16:37 UTC by Ralf Corsepius
Modified: 2017-05-16 11:16 UTC (History)
12 users (show)

Fixed In Version: rpcbind-0.2.4-4.fc25 rpcbind-0.2.3-17.rc2.fc24 rpcbind-0.2.4-5.fc25 rpcbind-0.2.4-6.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-24 18:56:13 UTC


Attachments (Terms of Use)

Description Ralf Corsepius 2017-01-22 16:37:57 UTC
Description of problem:
On all of my systems, with today's update, rpcbind has started to fail at bootup:



# systemctl status rpcbind.service 
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2017-01-22 17:20:55 CET; 12min ago
     Docs: man:rpcbind(8)
  Process: 573 ExecStart=/usr/bin/rpcbind $RPCBIND_OPTIONS -w -f (code=exited, status=1/FAILURE)
 Main PID: 573 (code=exited, status=1/FAILURE)

Jan 22 17:20:55 troy rpcbind[573]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
Jan 22 17:20:55 troy systemd[1]: rpcbind.service: Main process exited, code=exited, status=1/FAILURE
Jan 22 17:20:55 troy systemd[1]: Failed to start RPC Bind.
Jan 22 17:20:55 troy systemd[1]: rpcbind.service: Unit entered failed state.
Jan 22 17:20:55 troy systemd[1]: rpcbind.service: Failed with result 'exit-code'.


Version-Release number of selected component (if applicable):
rpcbind-0.2.4-2.fc25.x86_64

How reproducible:
Always, on all of my machines

Actual results:
c.f. above

Expected results:
function.

Additional info:
This also seems to cause yp/nis to fail.

Comment 1 Ralf Corsepius 2017-01-22 17:04:56 UTC
The culprit definitely is the patch you added to 0.2.4-2.fc25.

With 0.2.4-1.fc25.x86_64, though rpcbind raises a warning on '/run/rpcbind', it at least starts up, and yp/nis keeps working:

# systemctl status rpcbind
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; disabled; vendor preset: disabled)
   Active: active (running) since Sun 2017-01-22 17:56:50 CET; 41s ago
     Docs: man:rpcbind(8)
 Main PID: 591 (rpcbind)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/rpcbind.service
           └─591 /usr/bin/rpcbind -w -f

Jan 22 17:56:50 troy rpcbind[591]: mkdir_warmstart: mkdir failed '/run/rpcbind', errno 13 (Permission denied)
Jan 22 17:56:50 troy systemd[1]: Started RPC Bind.

Comment 2 Ralf Corsepius 2017-01-23 09:40:29 UTC
I think there are several bugs interacting. However one bug seems obvious: 

The mover from /run/ to /run/rpcbind/ wasn't reflected to systemd/rpcbind.socket

A quick fix would be to add this to %prep in rpcbind.spec:

sed -i -e 's,/run/rpcbind.sock,/run/rpcbind/rpcbind.sock,' systemd/rpcbind.socket

Comment 3 Ralf Corsepius 2017-01-23 15:48:41 UTC
(In reply to Ralf Corsepius from comment #2)
> A quick fix would be to add this to %prep in rpcbind.spec:

I have to correct myself. This doesn't work. It breaks rpcinfo.

Comment 4 Chris Schanzle 2017-01-23 16:08:35 UTC
Thanks for filing this bug and a clue as to the fix.  Until a new package is built, creating the below file is a workaround:

cat /etc/systemd/system/rpcbind.socket.d/fix-socket.conf 
[Socket]
ListenStream=/run/rpcbind/rpcbind.sock

hope it helps someone else

Comment 5 Fedora Update System 2017-01-23 20:23:40 UTC
rpcbind-0.2.3-16.rc2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a07577f460

Comment 6 Fedora Update System 2017-01-23 20:24:06 UTC
rpcbind-0.2.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c43a81dc30

Comment 7 Chris Schanzle 2017-01-24 15:28:48 UTC
rpcbind-0.2.4-3.fc25 does not start on boot properly; ypbind does not bind.
commenting DefaultDependencies=no from service file works.
Why are you using that option?

Comment 8 Fedora Update System 2017-01-25 01:22:25 UTC
rpcbind-0.2.3-16.rc2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a07577f460

Comment 9 Steve Dickson 2017-01-28 17:40:34 UTC

(In reply to Ralf Corsepius from comment #2)
> I think there are several bugs interacting. However one bug seems obvious: 
> 
> The mover from /run/ to /run/rpcbind/ wasn't reflected to
> systemd/rpcbind.socket
> 
> A quick fix would be to add this to %prep in rpcbind.spec:
> 
> sed -i -e 's,/run/rpcbind.sock,/run/rpcbind/rpcbind.sock,'
> systemd/rpcbind.socket

I have no idea why this would matter... ListenStream= is
a systemd thing and that option defines path where the 
socket should be created. That path is not defined
anywhere in the rpcbind code only in the rpcbind.sock
file. 

So this just does not make any sense to me...

Comment 10 Fedora Update System 2017-01-28 21:41:38 UTC
rpcbind-0.2.3-17.rc2.fc24 rpcbind-0.2.3-17.rc2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-44ec8c7a0e

Comment 11 Fedora Update System 2017-01-29 23:17:39 UTC
rpcbind-0.2.3-17.rc2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-44ec8c7a0e

Comment 12 Fedora Update System 2017-02-01 21:18:53 UTC
rpcbind-0.2.4-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ad932714f2

Comment 13 Fedora Update System 2017-02-02 22:49:58 UTC
rpcbind-0.2.4-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ad932714f2

Comment 14 Fedora Update System 2017-02-03 20:49:48 UTC
rpcbind-0.2.4-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-02-03 21:48:41 UTC
rpcbind-0.2.3-17.rc2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Jed Reynolds 2017-02-10 23:33:21 UTC
Broken for me. Install of F25 attempts to find /run/rpcbind/rpcbind.lock but file is in /run/rpcbind.lock.

Comment 17 Damian Wrobel 2017-02-15 15:56:13 UTC
Also doesn't work for me on arm:

[root@rpi3 run]# rpm -qv rpcbind
rpcbind-0.2.4-4.fc25.armv7hl

[root@rpi3 run]# systemctl start rpcbind
Job for rpcbind.service failed because the control process exited with error code.
See "systemctl status rpcbind.service" and "journalctl -xe" for details.
[root@rpi3 run]# systemctl status rpcbind
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2017-02-15 16:46:55 CET; 8s ago
     Docs: man:rpcbind(8)
  Process: 2166 ExecStart=/usr/bin/rpcbind $RPCBIND_OPTIONS -w -f (code=exited, status=1/FAILURE)
 Main PID: 2166 (code=exited, status=1/FAILURE)

Feb 15 16:46:55 rpi3 systemd[1]: Starting RPC Bind...
Feb 15 16:46:55 rpi3 rpcbind[2166]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
Feb 15 16:46:55 rpi3 systemd[1]: rpcbind.service: Main process exited, code=exited, status=1/FAILURE
Feb 15 16:46:55 rpi3 systemd[1]: Failed to start RPC Bind.
Feb 15 16:46:55 rpi3 systemd[1]: rpcbind.service: Unit entered failed state.
Feb 15 16:46:55 rpi3 systemd[1]: rpcbind.service: Failed with result 'exit-code'.

Workaround:
# mkdir -p /run/rpcbind

Comment 18 orcolat 2017-02-24 07:34:11 UTC
Not sure this is useful info, but

rpcbind.x86_64    0.2.4-4.fc25    @updates

worked to fix the service error still present at version 0.2.4-2.fc25 on an LXDE spin with kernel 4.9.5-200.fc25.x86_64

Comment 19 Fedora Update System 2017-03-21 17:25:49 UTC
rpcbind-0.2.4-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-66c84b1ba8

Comment 20 Fedora Update System 2017-03-21 17:26:24 UTC
rpcbind-0.2.4-6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5c5fcde1a0

Comment 21 Fedora Update System 2017-03-22 15:27:51 UTC
rpcbind-0.2.4-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5c5fcde1a0

Comment 22 Fedora Update System 2017-03-22 20:21:48 UTC
rpcbind-0.2.4-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-66c84b1ba8

Comment 23 Fedora Update System 2017-03-24 18:56:13 UTC
rpcbind-0.2.4-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2017-04-01 17:24:24 UTC
rpcbind-0.2.4-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Maël Lavault 2017-04-11 07:25:02 UTC
Issue is still here with rpcbind-0.2.4-5.fc25

Comment 26 Steve Dickson 2017-04-13 14:35:46 UTC
(In reply to Maël Lavault from comment #25)
> Issue is still here with rpcbind-0.2.4-5.fc25

This must be a different problem

Comment 27 RobbieTheK 2017-05-15 15:18:07 UTC
With rpcbind-0.2.4-5.rc1.fc25.x86_64 after reboot ypbind was failing and showing these errors:
May 15 10:56:35 ourserver systemd: Starting RPC Bind...
May 15 10:56:35 ourserver rpcbind: rpcbind: pmap_prot.c:50: xdr_pmap: Assertion `regs != NULL' failed.
May 15 10:56:35 ourserver systemd: Started RPC Bind.
May 15 10:56:35 ourserver systemd: rpcbind.service: Main process exited, code=killed, status=6/ABRT
May 15 10:56:35 ourserver systemd: rpcbind.service: Unit entered failed state.
May 15 10:56:35 ourserver systemd: rpcbind.service: Failed with result 'signal'.

Oddly rpcbind status was showing ok just a failure on ypbind:
-- Unit rpcbind.service has finished starting up.
-- 
-- The start-up result is done.
May 15 10:58:15 ourserver systemd[1]: rpcbind.service: Main process exited, code=killed, status=6/ABRT
May 15 10:58:15 ourserver systemd[1]: rpcbind.service: Unit entered failed state.
May 15 10:58:15 ourserver systemd[1]: rpcbind.service: Failed with result 'signal'.
May 15 10:58:17 ourserver ypbind[2631]: Binding took 46 seconds
May 15 10:58:17 ourserver ypbind[2633]: NIS server for domain divscimath is not responding.
May 15 10:58:17 ourserver ypbind[2634]: Killing ypbind with PID 2290.
May 15 10:58:17 ourserver ypbind[2290]: 2292: Signal (15) for quitting program arrived.
May 15 10:58:17 ourserver systemd[1]: Starting RPC Bind...
-- Subject: Unit rpcbind.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit rpcbind.service has begun starting up.
May 15 10:58:17 ourserver ypbind[2635]: Try increase NISTIMEOUT in /etc/sysconfig/ypbind
May 15 10:58:17 ourserver systemd[1]: ypbind.service: Control process exited, code=exited status=1
May 15 10:58:17 ourserver systemd[1]: Started RPC Bind.
-- Subject: Unit rpcbind.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit rpcbind.service has finished starting up.
-- 
-- The start-up result is done.
May 15 10:58:18 ourserver systemd[1]: Failed to start NIS/YP (Network Information Service) Clients to NIS Domain Binder.
-- Subject: Unit ypbind.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit ypbind.service has failed.
-- 
-- The result is failed.
May 15 10:58:18 ourserver systemd[1]: ypbind.service: Unit entered failed state.
May 15 10:58:18 ourserver systemd[1]: ypbind.service: Failed with result 'exit-code'.


Downgraded to rpcbind-0.2.3-11.rc1.fc25.x86_64 and both ypbind and rpcbind start fine.


Note You need to log in before you can comment on or make changes to this bug.