Bug 1415507 - FSCK starts every time when system boots and it takes a very long time
Summary: FSCK starts every time when system boots and it takes a very long time
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lukáš Czerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 21:09 UTC by LászlóTóth
Modified: 2017-09-13 11:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-13 11:51:13 UTC
Type: Bug


Attachments (Terms of Use)

Description LászlóTóth 2017-01-22 21:09:29 UTC
Description of problem:


Version-Release number of selected component (if applicable): 25


How reproducible: always


Steps to Reproduce:

1. Just reboot the system

Actual results: Every time starts fsck which takes long (3-5 minutes).


Expected results: I would like to cancel it and set up system to do not start fsck process every time.


Additional info: This is an old laptop. I am using two partitions. First one /dev/sda1 which is tuned by tune2fs but /dev/sda2 is an LVM. It can not be tuned by tune2fs and this partition is very large (900 GB).

Comment 1 LászlóTóth 2017-01-22 21:11:22 UTC
I need a workaround if exists. (I am new in Fedora. I have experiences in Debian Linux).

Comment 2 Ondrej Vasik 2017-01-23 19:41:26 UTC
Component filesystem has nothing to do with filesystems generally. I don't know what is the right component, but let's try e2fsprogs, where tune2fs originates. Its maintainer can probably reassign it further to right component(or close it, if this behaviour is expected).

As a quick answer, you can disable fsck after boot temporarily by adding 'fastboot' GRUB parameter before booting, though.

Comment 3 Lukáš Czerner 2017-01-25 10:48:29 UTC
Hello,

nowadays freshly made file systems are not going to be checked regularly. Which makes me think that either your file system is older, but even then it would not check it on every boot, or you changed some options, or the file system is indeed corrupted, or it was not unmounted properly.

Please provide the output of the following command for every file system in question.

tune2fs -l <device>

Thanks!
-Lukas

Comment 4 LászlóTóth 2017-01-26 17:16:40 UTC
Hello Lukas!

I have edited /etc/fstab file and I could disable there the checking process. 

I did that you asked. 

/dev/fedora-home


tune2fs 1.43.3 (04-Sep-2016)
Filesystem volume name:   <none>
Last mounted on:          /home
Filesystem UUID:          fc57aee7-ffea-45f7-8b41-d306f9d0e589
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype needs_recovery extent 64bit flex_bg sparse_super large_file huge_file dir_nlink extra_isize
Filesystem flags:         signed_directory_hash 
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              57319424
Block count:              229263360
Reserved block count:     11463168
Free blocks:              224782744
Free inodes:              57286698
First block:              0
Block size:               4096
Fragment size:            4096
Group descriptor size:    64
Reserved GDT blocks:      1024
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         8192
Inode blocks per group:   512
Flex block group size:    16
Filesystem created:       Fri Jan  1 01:45:50 2010
Last mount time:          Mon Jul 25 21:50:09 2016
Last write time:          Mon Jul 25 21:50:09 2016
Mount count:              8
Maximum mount count:      -1
Last checked:             Mon Jul 25 21:50:06 2016
Check interval:           0 (<none>)
Lifetime writes:          20 GB
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:	          256
Required extra isize:     32
Desired extra isize:      32
Journal inode:            8
First orphan inode:       46414477
Default directory hash:   half_md4
Directory Hash Seed:      12d588b1-29ec-4577-85a0-6109ba4d5e9b
Journal backup:           inode blocks



/dev/fedora-root

tune2fs 1.43.3 (04-Sep-2016)
Filesystem volume name:   <none>
Last mounted on:          /
Filesystem UUID:          519f4424-81f1-45d7-ba36-c84ac424e6b3
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype needs_recovery extent 64bit flex_bg sparse_super large_file huge_file dir_nlink extra_isize
Filesystem flags:         signed_directory_hash 
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              3276800
Block count:              13107200
Reserved block count:     655360
Free blocks:              10102592
Free inodes:              2924974
First block:              0
Block size:               4096
Fragment size:            4096
Group descriptor size:    64
Reserved GDT blocks:      1024
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         8192
Inode blocks per group:   512
Flex block group size:    16
Filesystem created:       Fri Jan  1 01:45:37 2010
Last mount time:          Mon Jul 25 21:49:56 2016
Last write time:          Mon Jul 25 21:49:51 2016
Mount count:              20
Maximum mount count:      -1
Last checked:             Mon Jul 25 21:49:51 2016
Check interval:           0 (<none>)
Lifetime writes:          19 GB
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:	          256
Required extra isize:     32
Desired extra isize:      32
Journal inode:            8
First orphan inode:       2752678
Default directory hash:   half_md4
Directory Hash Seed:      cfd74b1b-7a3c-4644-85a8-a85b68315696
Journal backup:           inode blocks

/dev/sda1

tune2fs 1.43.3 (04-Sep-2016)
Filesystem volume name:   <none>
Last mounted on:          /boot
Filesystem UUID:          2d55f934-8ecd-476a-8d80-ee4550d8dbe5
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype needs_recovery extent 64bit flex_bg sparse_super large_file huge_file dir_nlink extra_isize
Filesystem flags:         signed_directory_hash 
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              65536
Block count:              262144
Reserved block count:     13107
Free blocks:              204222
Free inodes:              65096
First block:              0
Block size:               4096
Fragment size:            4096
Group descriptor size:    64
Reserved GDT blocks:      127
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         8192
Inode blocks per group:   512
Flex block group size:    16
Filesystem created:       Fri Jan  1 01:49:15 2010
Last mount time:          Mon Jul 25 21:50:09 2016
Last write time:          Mon Jul 25 21:50:09 2016
Mount count:              8
Maximum mount count:      -1
Last checked:             Mon Jul 25 21:50:06 2016
Check interval:           0 (<none>)
Lifetime writes:          288 MB
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:	          256
Required extra isize:     32
Desired extra isize:      32
Journal inode:            8
Default directory hash:   half_md4
Directory Hash Seed:      3d15ab11-b8aa-47ea-9cdc-5cb6486b78fb
Journal backup:           inode blocks

Regards,

László Tóth

Comment 5 Eric Sandeen 2017-01-27 14:07:23 UTC
> Filesystem created:       Fri Jan  1 01:45:50 2010
> Last mount time:          Mon Jul 25 21:50:09 2016
> Last write time:          Mon Jul 25 21:50:09 2016
> Mount count:              8
> Maximum mount count:      -1
> Last checked:             Mon Jul 25 21:50:06 2016
> Check interval:           0 (<none>)

So, you have no maximum mount count or check interval set, but your clock seems wrong.  (Jul 2016?)

Fix your system clock (check the bios as well as the system) and the problem will probably go away.

Comment 6 Lukáš Czerner 2017-09-13 11:51:13 UTC
This is not a bug, solution has been suggested and we have no update from reporter for 8 months. I am closing this one. Please feel free to reopen if needed.

Thanks!
-Lukas


Note You need to log in before you can comment on or make changes to this bug.