Bug 141551 - push: rhn_check picks up scheduled actions multiple times
push: rhn_check picks up scheduled actions multiple times
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-12-01 17:55 EST by Max Spevack
Modified: 2007-07-31 11:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-12-01 17:55:11 EST
Description of problem:
if you schedule a package install, rhn_check will pick the action up
multiple times (because it takes more than 10 seconds for the action
to finish) and as a result, all of the actions fail.

Version-Release number of selected component (if applicable):
-68 ISO

How reproducible:
Always

Steps to Reproduce:
1.  setup a client/server that can do push
2.  schedule a package install
3.  watch it fail
  
Actual results:
failure

Expected results:
pass

Additional info:
Comment 1 Mihai Ibanescu 2004-12-01 22:03:06 EST
Should be fixed now (versions 0.4-14 for AS2.1 and 0.4-15 for RHEL3).

Test case is listed in the Steps to Reproduce.
Comment 2 Fanny Augustin 2004-12-08 11:34:35 EST
Looks good on QA.
Comment 3 Todd Warner 2005-03-22 13:00:30 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.