Bug 1415576 - Can't log in guest if check password option with blank password in virt-manager
Summary: Can't log in guest if check password option with blank password in virt-manager
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 06:19 UTC by mxie@redhat.com
Modified: 2017-01-25 09:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 09:41:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-manager-debug (20.15 KB, text/plain)
2017-01-23 06:19 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-01-23 06:19:01 UTC
Created attachment 1243514 [details]
virt-manager-debug

Description of problem:
Can't log in guest if check password option with blank password in virt-manager

Version-Release number of selected component (if applicable):
virt-manager-1.4.0-2.el7.noarch
libvirt-2.0.0-10.el7_3.4.x86_64
qemu-kvm-rhev-2.6.0-28.el7_3.3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a shutdown guest no matter graphic mode is spice or vnc in virt-manager
2. Open the guest hardware details info and check the password option but don't input any password in display option
3. Power on the guest,guest console will ask user to type password, don't input any password and click login button, login failed.


Actual results:
As subject

Expected results:
There are 3 options:

1.The guest should be logged in without inputting password when check password option with blank password in virt-manager
2.Remove the button of password option like rhel6 virt-manager
3.guest console will not ask user to type password if check password option with blank password in virt-manager

Additional info:

Comment 1 Pavel Hrdina 2017-01-25 09:41:47 UTC
This is not a bug, it's actually a feature, see the following bugs:

https://bugzilla.redhat.com/show_bug.cgi?id=1180092
https://bugzilla.redhat.com/show_bug.cgi?id=667976


Note You need to log in before you can comment on or make changes to this bug.