Bug 1415584 - [Stress] : Heal Info output is strange and inconsistent.
Summary: [Stress] : Heal Info output is strange and inconsistent.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Pranith Kumar K
QA Contact: Ambarish
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 07:17 UTC by Ambarish
Modified: 2017-08-24 06:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-24 06:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ambarish 2017-01-23 07:17:56 UTC
Description of problem:
-----------------------


Gluster v heal info output is strange and inconsistent.

Here is a snippet :

<snip>

<gfid:34de7c8c-e582-450b-9cbe-e3129895f896> 
<gfid:67c225d4-2a7a-4122-a8c1-b9583a9a7d42>/d_006 
<gfid:388f3e7f-d224-45df-8567-07c9414f9fb9>/_03_11407_ 
<gfid:853d2ba5-231f-45d9-a1a5-326a6ead5703> 
<gfid:acf3271e-9e17-44f3-95c1-ccd9d02c4ba9> 
<gfid:1f008292-1701-44d7-83ab-c373edc1bfc0> 
/file_srcdir/gqac010.sbu.lab.eng.bos.redhat.com/thrd_01/d_004/d_000/d_007/_01_40741_ 
<gfid:b05aebd9-401e-4534-b8ff-a9090a29bedd> 
<gfid:7f689c6f-d170-4826-9a1f-9cdee59f6d61> 
<gfid:4fd6b85f-9aa3-4a65-b016-a5797d953da4> 
<gfid:1d7f360d-33a9-47ec-a6ae-5c3c27c4842f>/d_001/d_001/_02_41167_ 
/file_srcdir/gqac010.sbu.lab.eng.bos.redhat.com/thrd_05/d_004/d_001/d_002/_05_41210_ 
<gfid:e0af109d-04a9-40ee-87e5-cc606b4756ab> 
<gfid:840c2ac8-7fdf-4682-acb5-41adfd01ebda> 
<gfid:68bc6dfd-0319-4659-8f4b-f03fbe09729d> 
<gfid:1d7f360d-33a9-47ec-a6ae-5c3c27c4842f>/d_001/d_002/_02_41283_ 
<gfid:53757f8f-cc41-4f1d-8932-98893c2d3219> 
<gfid:226f873f-fe24-4864-ab53-b1744ed38a30> 
<gfid:c5b7687a-7498-43e1-994f-bd3bceb7a6eb> 
<gfid:40d9cba4-21f1-4a2a-9427-3fe81d23d7b5> 
<gfid:cc5832da-26de-4c91-b0d2-5ae58b07a0bd> 
<gfid:1d7f360d-33a9-47ec-a6ae-5c3c27c4842f>/d_001/d_007/_02_41706_ 
<gfid:c82b3f89-6bb5-4f00-9930-303158663153> 
<gfid:128fa9e8-6d97-45cb-a87b-d805f2c547be>/d_001/d_007/_00_41748_ 
<gfid:6397f0f7-3f68-4c4e-a2ff-0937df8ce4ed> 
<gfid:3d6acc7a-fe67-4e5e-9fd5-ef99e89777ae> 
<gfid:9a82c2a2-f310-4670-b76a-c124262e803f> 
<gfid:64583fa2-2805-4f0c-9aaf-fdf9758713ea> 
<gfid:2eab917f-fc34-42f5-9af0-65583638ce43> 
<gfid:f1e6b279-399e-4b42-b2a4-6e5bd3c17170> 
/file_srcdir/gqac010.sbu.lab.eng.bos.redhat.com/thrd_01/d_004/d_002/d_001/_01_42104_ 
<gfid:eb60484e-a91c-4173-a15d-85b5c40d3c1c> 
<gfid:45cb569c-ebeb-45da-ba68-1338e6d0163c> 
<gfid:57a61267-579c-4ab2-b160-cded046b9f89> 
<gfid:3ee0b2ff-142b-4787-9d40-ebc5356b5301> 
<gfid:da2f57b2-d284-42bf-8f55-4b6e43876197> 
<gfid:4a3b12eb-9df8-41f2-bca0-39899cec8435> 
<gfid:ca9b975b-3b79-445c-bff7-13aa30344b8a> 
<gfid:d994250b-55f0-4199-a833-7beb39703afb> 
<gfid:44f25205-2f5d-4634-90bd-f3f1f5f66790> 
<gfid:270e0325-8b81-4a35-98f0-410a3f78c73e> 
<gfid:05513321-cbd4-4152-8cbd-56f2d314d319> 
<gfid:582a550e-bf6a-475e-871e-73a6ef7a9a56> 
<gfid:32b55e74-8ad7-4a8a-b928-df0718e2b9f2> 
<gfid:bbe11548-d777-433f-a655-bcbed7321880> 
<gfid:128fa9e8-6d97-45cb-a87b-d805f2c547be>/d_002/d_003/_00_42337_ 
<gfid:d9a1a0a8-a9b2-4fd2-b2c3-ef1f43a11a00> 
/file_srcdir/gqac010.sbu.lab.eng.bos.redhat.com/thrd_07/d_004/d_002/d_002/_07_42297_ 
<gfid:bd247e92-515a-4768-b444-45a6403eaf03> 
/snip>


The same command has the following as output for pending heals:

A) gfid : <gfid:9a82c2a2-f310-4670-b76a-c124262e803f> 

B) filename : /file_srcdir/gqac010.sbu.lab.eng.bos.redhat.com/thrd_07/d_004/d_002/d_002/_07_42297_ 

C_ Neither filename nor gfid but a weird concatenation of both : <gfid:128fa9e8-6d97-45cb-a87b-d805f2c547be>/d_002/d_003/_00_42337_ 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

glusterfs-3.8.4-12.el7rhgs.x86_64

How reproducible:
-----------------

1/1


Actual results:
---------------

Weird and inconsistent output with heal info


Expected results:
-----------------

Readable,consistent output.

Additional info:
----------------

[root@gqas009 ~]# gluster v status
Status of volume: gluster_shared_storage
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick gqas015.sbu.lab.eng.bos.redhat.com:/v
ar/lib/glusterd/ss_brick                    49152     0          Y       26457
Brick gqas014.sbu.lab.eng.bos.redhat.com:/v
ar/lib/glusterd/ss_brick                    49152     0          Y       25391
Brick gqas009.sbu.lab.eng.bos.redhat.com:/v
ar/lib/glusterd/ss_brick                    49152     0          Y       25747
Self-heal Daemon on localhost               N/A       N/A        Y       17960
Self-heal Daemon on gqas014.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17200
Self-heal Daemon on gqas010.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       13756
Self-heal Daemon on gqas015.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17415
 
Task Status of Volume gluster_shared_storage
------------------------------------------------------------------------------
There are no active volume tasks
 
Status of volume: replicate
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks12/bricknew                            49153     0          Y       27931
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks12/bricknew                            49152     0          Y       27177
Self-heal Daemon on localhost               N/A       N/A        Y       17960
Self-heal Daemon on gqas010.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       13756
Self-heal Daemon on gqas015.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17415
Self-heal Daemon on gqas014.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17200
 
Task Status of Volume replicate
------------------------------------------------------------------------------
There are no active volume tasks
 
Status of volume: testvol
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks1/brick1                               49158     0          Y       29725
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks1/brick                                49164     0          Y       24750
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks1/brick                                49164     0          Y       24867
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks1/brick                                49164     0          Y       25931
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks3/brick                                49165     0          Y       25201
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks3/brick                                49165     0          Y       24769
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks2/brick1                               49153     0          Y       29771
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks2/brick                                49166     0          Y       24788
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks2/brick                                49165     0          Y       24886
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks2/brick                                49165     0          Y       25950
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks3/brick                                49166     0          Y       24905
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks3/brick                                49166     0          Y       25969
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks4/brick1                               49154     0          Y       29827
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks4/brick                                49167     0          Y       24807
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks4/brick                                49167     0          Y       25988
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks4/brick                                49167     0          Y       24924
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks5/brick                                49168     0          Y       25258
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks5/brick                                49168     0          Y       24826
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks6/brick                                49169     0          Y       25277
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks6/brick                                49169     0          Y       24845
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks6/brick                                49168     0          Y       26007
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks6/brick                                49168     0          Y       24943
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks5/brick                                49169     0          Y       24962
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks5/brick                                49169     0          Y       26026
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks7/brick1                               49155     0          Y       29909
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks7/brick                                49170     0          Y       24864
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks7/brick                                49170     0          Y       26045
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks7/brick                                49170     0          Y       24981
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks8/brick                                49171     0          Y       24883
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks8/brick                                49171     0          Y       25315
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks9/brick                                49172     0          Y       25336
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks9/brick                                49172     0          Y       24902
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks9/brick                                49171     0          Y       26064
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks9/brick                                49171     0          Y       25000
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks8/brick                                49172     0          Y       25019
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks8/brick                                49172     0          Y       26083
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks10/brick                               49173     0          Y       25355
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks10/brick                               49173     0          Y       24921
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks10/brick                               49173     0          Y       26102
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks10/brick                               49173     0          Y       25038
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks11/brick1                              49156     0          Y       30009
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks11/brick                               49174     0          Y       24940
Brick gqas009.sbu.lab.eng.bos.redhat.com:/b
ricks12/brick                               49175     0          Y       25393
Brick gqas010.sbu.lab.eng.bos.redhat.com:/b
ricks12/brick                               49175     0          Y       24959
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks12/brick                               49174     0          Y       26121
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks12/brick                               49174     0          Y       25057
Brick gqas014.sbu.lab.eng.bos.redhat.com:/b
ricks11/brick                               49175     0          Y       25076
Brick gqas015.sbu.lab.eng.bos.redhat.com:/b
ricks11/brick                               49175     0          Y       26140
Self-heal Daemon on localhost               N/A       N/A        Y       17960
Self-heal Daemon on gqas010.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       13756
Self-heal Daemon on gqas015.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17415
Self-heal Daemon on gqas014.sbu.lab.eng.bos
.redhat.com                                 N/A       N/A        Y       17200
 
Task Status of Volume testvol
------------------------------------------------------------------------------
Task                 : Rebalance           
ID                   : 60d3e3e4-661c-4520-9f5f-482d95d81a82
Status               : in progress         
 
[root@gqas009 ~]#

Comment 3 Pranith Kumar K 2017-01-23 14:07:17 UTC
Ambarish,
     It tries to print the filepath as much as it knows. Sometimes the brick doesn't know anything about the path. Sometimes it knows partial path. I agree it has been a pain usability wise but it has been helpful because once you know parent directory you can figure out the complete path (It will take more I/O cycles, so we don't do it by default). At the moment there are no plans to change this part of the output much. So I am inclined to close this if you also are fine with it.

Comment 5 Ambarish 2017-02-17 12:57:51 UTC
SGTM,Pranith!

Thanks.


Note You need to log in before you can comment on or make changes to this bug.