Bug 141560 - use ssl "whenever possible" does not work with mail accounts in evolution
use ssl "whenever possible" does not work with mail accounts in evolution
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 21:24 EST by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 10:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2004-12-01 21:24:36 EST
Description of problem:
I tried setting use ssl to "whenever possible" for my pop account and
it states that it fails to negotiate secure connection.  When I set it
to always use ssl it works without a problem

Version-Release number of selected component (if applicable):
evolution-2.0.2-3

How reproducible:
always

Steps to Reproduce:
1.create a pop account with a server that accepts secure and unsecure
connections
2.choose use ssl whenever possible
3.
  
Actual results:
Fails to negotiate a connection

Expected results:
Should work

Additional info:
I assume this is a general problem.  My mail server is
magenta.ucdavis.edu.  If it works for you, it must be the interaction
of evolution with that mail server.  That server is set up by the
university and I am certain it is configured correctly.
Comment 1 David Kaplan 2004-12-01 21:57:42 EST
I also tried using SSL to send email from this account (outgoing
server is same as incoming).  This does not work in "always" mode, but
does in "whenever possible" mode.

Given the problems I am having with receiving mail, sending mail and
LDAP with SSL (see Bug #141563), could there be a general problem with
SSL in evolution?  
   
Comment 2 Derek Poon 2004-12-10 09:48:11 EST
I have just filed a bug in the Ximian bug database
http://bugzilla.ximian.com/show_bug.cgi?id=70424 which might be
related to the outgoing problem you described in comment #1.
Comment 3 Matthew Miller 2006-07-10 19:43:45 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 4 John Thacker 2006-11-05 10:58:17 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.
Comment 5 David Kaplan 2006-11-05 13:58:49 EST
I have to say that this is absurd.  Basically, I filed a series of bugs in 2004
when FC3 was current.  These got no response whatsoever from Fedora, despite the
fact that other users reported similar problems.  I don't even know if anyone
attempted to check the bugs.  Then, TWO YEARS LATER!, I get a message that the
bug is being closed because FC3 is no longer current and I was unresponsive.  I
was unresponsive!  Of course FC3 is no longer current, the bug was filed 2 years
ago! This is a fundamental problem with Fedora - there is basically no interest
in fixing usability bugs and what interest there is usually lags the bug reports
by centuries.  This is why I have given up on Fedora (despite early attempts to
be a fedora-extras package maintainer, to make regular and detailed bug reports,
to offer debugging assistance, etc.) and changed to Ubuntu.

To all who read this - there is no point in filing Fedora UI bugs!

Note You need to log in before you can comment on or make changes to this bug.